summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.md4
m---------kafka-src0
-rw-r--r--kafka/client.py2
-rw-r--r--kafka/consumer.py1
-rw-r--r--setup.py2
-rw-r--r--test/integration.py1
6 files changed, 7 insertions, 3 deletions
diff --git a/README.md b/README.md
index a1b88b4..08fbd67 100644
--- a/README.md
+++ b/README.md
@@ -5,7 +5,7 @@ high-level consumer and producer classes. Request batching is supported by the
protocol as well as broker-aware request routing. Gzip and Snappy compression
is also supported for message sets.
-Compatible with Apache Kafka 0.8.1
+Compatible with Apache Kafka 0.8.0
http://kafka.apache.org/
@@ -16,7 +16,7 @@ Copyright 2013, David Arthur under Apache License, v2.0. See `LICENSE`
# Status
I'm following the version numbers of Kafka, plus one number to indicate the
-version of this project. The current version is 0.8.1-1. This version is under
+version of this project. The current version is 0.8.0-1. This version is under
development, APIs are subject to change.
# Usage
diff --git a/kafka-src b/kafka-src
-Subproject 9ff4e8eb10e0ddd86f257e99d55971a13242660
+Subproject 3c27988ca4036985f4c7bef62b9bbae3f95f0fb
diff --git a/kafka/client.py b/kafka/client.py
index 9893737..5a58b2e 100644
--- a/kafka/client.py
+++ b/kafka/client.py
@@ -216,6 +216,7 @@ class KafkaClient(object):
return out
def send_offset_commit_request(self, group, payloads=[], fail_on_error=True, callback=None):
+ raise NotImplementedError("Broker-managed offsets not supported in 0.8")
resps = self._send_broker_aware_request(payloads,
partial(KafkaProtocol.encode_offset_commit_request, group=group),
KafkaProtocol.decode_offset_commit_response)
@@ -230,6 +231,7 @@ class KafkaClient(object):
return out
def send_offset_fetch_request(self, group, payloads=[], fail_on_error=True, callback=None):
+ raise NotImplementedError("Broker-managed offsets not supported in 0.8")
resps = self._send_broker_aware_request(payloads,
partial(KafkaProtocol.encode_offset_fetch_request, group=group),
KafkaProtocol.decode_offset_fetch_response)
diff --git a/kafka/consumer.py b/kafka/consumer.py
index b9d4d9e..4ce62e2 100644
--- a/kafka/consumer.py
+++ b/kafka/consumer.py
@@ -108,6 +108,7 @@ class SimpleConsumer(object):
partitions: list of partitions to commit, default is to commit all of them
"""
+ raise NotImplementedError("Broker-managed offsets not supported in 0.8")
# short circuit if nothing happened
if self.count_since_commit == 0:
diff --git a/setup.py b/setup.py
index d615694..bf61b56 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@ from distutils.core import setup
setup(
name="kafka-python",
- version="0.8.1-1",
+ version="0.8.0-1",
author="David Arthur",
author_email="mumrah@gmail.com",
url="https://github.com/mumrah/kafka-python",
diff --git a/test/integration.py b/test/integration.py
index 609cfc6..de91130 100644
--- a/test/integration.py
+++ b/test/integration.py
@@ -356,6 +356,7 @@ class TestKafkaClient(unittest.TestCase):
# Offset Tests #
####################
+ @unittest.skip("No supported until 0.8.1")
def test_commit_fetch_offsets(self):
req = OffsetCommitRequest("test_commit_fetch_offsets", 0, 42, "metadata")
(resp,) = self.client.send_offset_commit_request("group", [req])