summaryrefslogtreecommitdiff
path: root/docs/install.rst
diff options
context:
space:
mode:
authorWill Daly <will@edx.org>2015-01-04 12:23:10 -0500
committerWill Daly <will.e.daly@gmail.com>2015-01-15 18:01:40 -0500
commit01f378328e5383d05d52428b815f992eb2c536cb (patch)
tree2d3366ed91b9744efd40d935a460040150c6d4d8 /docs/install.rst
parent02c2b469003e2ddcb051dbb4d95977137050c19f (diff)
downloadkafka-python-01f378328e5383d05d52428b815f992eb2c536cb.tar.gz
Add Sphinx API docs
Diffstat (limited to 'docs/install.rst')
-rw-r--r--docs/install.rst79
1 files changed, 79 insertions, 0 deletions
diff --git a/docs/install.rst b/docs/install.rst
new file mode 100644
index 0000000..1dd6d4e
--- /dev/null
+++ b/docs/install.rst
@@ -0,0 +1,79 @@
+Install
+=======
+
+Install with your favorite package manager
+
+Latest Release
+--------------
+Pip:
+
+.. code:: bash
+
+ pip install kafka-python
+
+Releases are also listed at https://github.com/mumrah/kafka-python/releases
+
+
+Bleeding-Edge
+-------------
+
+.. code:: bash
+
+ git clone https://github.com/mumrah/kafka-python
+ pip install ./kafka-python
+
+Setuptools:
+
+.. code:: bash
+
+ git clone https://github.com/mumrah/kafka-python
+ easy_install ./kafka-python
+
+Using `setup.py` directly:
+
+.. code:: bash
+
+ git clone https://github.com/mumrah/kafka-python
+ cd kafka-python
+ python setup.py install
+
+
+Optional Snappy install
+-----------------------
+
+Install Development Libraries
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+Download and build Snappy from http://code.google.com/p/snappy/downloads/list
+
+Ubuntu:
+
+.. code:: bash
+
+ apt-get install libsnappy-dev
+
+OSX:
+
+.. code:: bash
+
+ brew install snappy
+
+From Source:
+
+.. code:: bash
+
+ wget http://snappy.googlecode.com/files/snappy-1.0.5.tar.gz
+ tar xzvf snappy-1.0.5.tar.gz
+ cd snappy-1.0.5
+ ./configure
+ make
+ sudo make install
+
+Install Python Module
+^^^^^^^^^^^^^^^^^^^^^
+
+Install the `python-snappy` module
+
+.. code:: bash
+
+ pip install python-snappy