summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaras Voinarovskiy <voyn1991@gmail.com>2017-10-14 11:22:06 +0000
committerTaras Voinarovskiy <voyn1991@gmail.com>2017-10-14 11:22:06 +0000
commit2d3608225d137dc8e43cb75e7ee4f20e98b59971 (patch)
tree355d70212512a7e203cfd3897ee3049a0300e2dd
parent3728bec653d4287f00c94009cb08eea803433c0d (diff)
downloadkafka-python-2d3608225d137dc8e43cb75e7ee4f20e98b59971.tar.gz
Add build_intergation job for makefileadd_makefile
-rw-r--r--Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/Makefile b/Makefile
index 82701e8..73c3ecf 100644
--- a/Makefile
+++ b/Makefile
@@ -1,26 +1,31 @@
# Some simple testing tasks (sorry, UNIX only).
FLAGS=
-KAFKA_VERSION=0.11.0.0
-SCALA_VERSION=2.11
+KAFKA_VERSION=0.11.0.1
+SCALA_VERSION=2.12
setup:
pip install -r requirements-dev.txt
pip install -Ue .
+servers/$(KAFKA_VERSION)/kafka-bin:
+ KAFKA_VERSION=$(KAFKA_VERSION) SCALA_VERSION=$(SCALA_VERSION) ./build_integration.sh
+
+build-integration: servers/$(KAFKA_VERSION)/kafka-bin
+
# Test and produce coverage using tox. This is the same as is run on Travis
-test36:
+test36: build-integration
KAFKA_VERSION=$(KAFKA_VERSION) SCALA_VERSION=$(SCALA_VERSION) tox -e py36 -- $(FLAGS)
-test27:
+test27: build-integration
KAFKA_VERSION=$(KAFKA_VERSION) SCALA_VERSION=$(SCALA_VERSION) tox -e py27 -- $(FLAGS)
# Test using py.test directly if you want to use local python. Useful for other
# platforms that require manual installation for C libraries, ie. Windows.
-test-local:
+test-local: build-integration
py.test --pylint --pylint-rcfile=pylint.rc --pylint-error-types=EF kafka test
-cov-local:
+cov-local: build-integration
py.test --pylint --pylint-rcfile=pylint.rc --pylint-error-types=EF --cov=kafka \
--cov-config=.covrc --cov-report html kafka test
@echo "open file://`pwd`/htmlcov/index.html"