summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDana Powers <dana.powers@gmail.com>2017-06-16 23:05:17 -0700
committerDana Powers <dana.powers@gmail.com>2017-06-16 23:05:17 -0700
commitbb626dbffba23e4cb20e99e9d48663a436c9ba76 (patch)
tree81d03a3aac68b9779564aa20a05d04217fcc8a90
parentb1a6d3301f0ed997e937dcc3b09a3cff27360cff (diff)
downloadkafka-python-bb626dbffba23e4cb20e99e9d48663a436c9ba76.tar.gz
Follow-up: support manual py26 testing; dont advertise 3.3 support
-rw-r--r--setup.py6
-rw-r--r--tox.ini7
2 files changed, 10 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 469b5b1..9dcdb8e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
-import sys
import os
+import sys
+
from setuptools import setup, Command, find_packages
# Pull version from source without importing
@@ -23,6 +24,8 @@ class Tox(Command):
test_require = ['tox', 'mock']
+if sys.version_info < (2, 7):
+ test_require.append('unittest2')
here = os.path.abspath(os.path.dirname(__file__))
@@ -51,7 +54,6 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
diff --git a/tox.ini b/tox.ini
index f1cb10e..a87e646 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{27,34,35,36,py}, docs
+envlist = py{26,27,34,35,36,py}, docs
[pytest]
testpaths = kafka test
@@ -19,12 +19,17 @@ deps =
python-snappy
lz4
xxhash
+ py26: unittest2
commands =
py.test {posargs:--pylint --pylint-rcfile=pylint.rc --pylint-error-types=EF --cov=kafka --cov-config=.covrc}
setenv =
PROJECT_ROOT = {toxinidir}
passenv = KAFKA_VERSION
+[testenv:py26]
+# pylint doesn't support python2.6
+commands = py.test {posargs:--cov=kafka --cov-config=.covrc}
+
[testenv:pypy]
# pylint is super slow on pypy...
commands = py.test {posargs:--cov=kafka --cov-config=.covrc}