summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenn Knowles <kenn.knowles@gmail.com>2013-05-22 14:26:56 -0700
committerKenn Knowles <kenn.knowles@gmail.com>2013-05-22 14:26:56 -0700
commit1a8e021d55129f7fbaf19a5517cc2dae50fc26b4 (patch)
treeb4acb77b55e30cd0c668dedfb3f850a374916552
parent1d440077163fd41ab459f901a4f6667bb759514d (diff)
parentc37332615e5af268eeb104e476cbaf4d1eaedf5c (diff)
downloadjsonpath-rw-1a8e021d55129f7fbaf19a5517cc2dae50fc26b4.tar.gz
Merge pull request #2 from kennknowles/coveralls
Coveralls
-rw-r--r--.coveragerc3
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml5
-rw-r--r--README.md5
4 files changed, 13 insertions, 2 deletions
diff --git a/.coveragerc b/.coveragerc
new file mode 100644
index 0000000..1e56ef0
--- /dev/null
+++ b/.coveragerc
@@ -0,0 +1,3 @@
+[run]
+branch = True
+source = jsonpath_rw
diff --git a/.gitignore b/.gitignore
index 7df8a89..a1e3ce0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,5 @@
/README.txt
/dist
/*.egg-info
+
+.coverage
diff --git a/.travis.yml b/.travis.yml
index eccc798..cc92859 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,4 +7,7 @@ python:
install:
- "pip install . --use-mirrors"
- "pip install pytest --use-mirrors"
-script: py.test
+ - "pip install coverage coveralls"
+script: coverage run setup.py test
+after_success:
+ - coveralls
diff --git a/README.md b/README.md
index d44833c..ba94760 100644
--- a/README.md
+++ b/README.md
@@ -3,7 +3,10 @@ Python JSONPath RW
https://github.com/kennknowles/python-jsonpath-rw
-[![Build Status](https://travis-ci.org/kennknowles/python-jsonpath-rw.png)](https://travis-ci.org/kennknowles/python-jsonpath-rw)
+[![Build Status](https://travis-ci.org/kennknowles/python-jsonpath-rw.png?branch=master)](https://travis-ci.org/kennknowles/python-jsonpath-rw)
+[![Test coverage](https://coveralls.io/repos/kennknowles/python-jsonpath-rw/badge.png?branch=master)](https://coveralls.io/r/kennknowles/python-jsonpath-rw)
+[![PyPi version](https://pypip.in/v/jsonpath-rw/badge.png)](https://pypi.python.org/pypi/jsonpath-rw)
+[![PyPi downloads](https://pypip.in/d/jsonpath-rw/badge.png)](https://pypi.python.org/pypi/jsonpath-rw)
This library provides a robust and significantly extended implementation of JSONPath for Python.
It is tested with Python 2.6, 2.7, 3.2, and 3.3.