summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenn Knowles <kenn.knowles@gmail.com>2013-05-01 17:55:05 -0400
committerKenn Knowles <kenn.knowles@gmail.com>2013-05-01 17:55:05 -0400
commit03e57bfdb50c8cf24474cbb1fa0861c10b80e4f5 (patch)
tree8fefbeee262fa6dc71bfc5317ab2d88994a064ee
parentfbf05a2eb1dd2499deee1e064056d53f803878e6 (diff)
downloadjsonpath-rw-03e57bfdb50c8cf24474cbb1fa0861c10b80e4f5.tar.gz
Explicitly specify README.txt encoding and bump to semver 1.1.11.1.1
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 84712d2..be9c4ca 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
import setuptools
+import io
import sys
import os.path
import subprocess
@@ -13,13 +14,13 @@ readme = 'README.txt' if os.path.exists('README.txt') else 'README.md'
setuptools.setup(
name='jsonpath-rw',
- version='1.1',
+ version='1.1.1',
description='A robust and significantly extended implementation of JSONPath for Python, with a clear AST for metaprogramming.',
author='Kenneth Knowles',
author_email='kenn.knowles@gmail.com',
url='https://github.com/kennknowles/python-jsonpath-rw',
license='Apache 2.0',
- long_description=open(readme).read(),
+ long_description=io.open(readme, encoding='utf-8').read(),
packages = ['jsonpath_rw'],
test_suite = 'tests',
install_requires = [ 'ply', 'decorator', 'six' ],