summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2020-05-18 13:26:05 -0700
committerDavid Lord <davidism@gmail.com>2020-05-18 13:29:50 -0700
commitf92617c46e5d2b38ea4dea880e28d84be142372c (patch)
tree5f80391dc9460a488142d2c275af3989dc708f42
parent39ce5717567d308533aaf9779b729025f720bded (diff)
downloaditsdangerous-f92617c46e5d2b38ea4dea880e28d84be142372c.tar.gz
fix pip cache and runner os
-rw-r--r--.github/workflows/tests.yaml36
1 files changed, 22 insertions, 14 deletions
diff --git a/.github/workflows/tests.yaml b/.github/workflows/tests.yaml
index 6500d40..e9f5f85 100644
--- a/.github/workflows/tests.yaml
+++ b/.github/workflows/tests.yaml
@@ -1,4 +1,4 @@
-name: tests
+name: Tests
on:
push:
branches:
@@ -11,34 +11,42 @@ on:
jobs:
tests:
name: ${{ matrix.name }}
- runs-on: ubuntu-latest
+ runs-on: ${{ matrix.os }}
strategy:
fail-fast: false
matrix:
include:
- - {name: Linux, python: '3.8', os: ubuntu-latest, toxenv: py}
- - {name: '3.7', python: '3.7', os: ubuntu-latest, toxenv: py}
- - {name: '3.6', python: '3.6', os: ubuntu-latest, toxenv: py}
- - {name: 'PyPy', python: pypy3, os: ubuntu-latest, toxenv: py}
- - {name: Style, python: '3.8', os: ubuntu-latest, toxenv: style}
- - {name: Docs, python: '3.8', os: ubuntu-latest, toxenv: docs}
- - {name: Windows, python: '3.8', os: windows-latest, toxenv: py}
- - {name: Mac, python: '3.8', os: macos-latest, toxenv: py}
+ - {name: Linux, python: '3.8', os: ubuntu-latest, tox: py38}
+ - {name: '3.7', python: '3.7', os: ubuntu-latest, tox: py37}
+ - {name: '3.6', python: '3.6', os: ubuntu-latest, tox: py36}
+ - {name: 'PyPy', python: pypy3, os: ubuntu-latest, tox: pypy3}
+ - {name: Style, python: '3.8', os: ubuntu-latest, tox: style}
+ - {name: Docs, python: '3.8', os: ubuntu-latest, tox: docs}
+ - {name: Windows, python: '3.8', os: windows-latest, tox: py38}
+ - {name: Mac, python: '3.8', os: macos-latest, tox: py38}
steps:
- uses: actions/checkout@v2
- uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python }}
+ - name: update pip
+ run: |
+ pip install -U wheel
+ pip install -U setuptools
+ pip install -U pip
+ - name: get pip cache dir
+ id: pip-cache
+ run: echo "::set-output name=dir::$(pip cache dir)"
- name: cache pip
uses: actions/cache@v1
with:
- path: ~/.cache/pip
- key: pip|${{ matrix.python }}|${{ hashFiles('requirements/*.txt') }} }}
+ path: ${{ steps.pip-cache.outputs.dir }}
+ key: pip|${{ runner.os }}|${{ matrix.python }}|${{ hashFiles('setup.py') }}|${{ hashFiles('requirements/*.txt') }}
- name: cache pre-commit
uses: actions/cache@v1
with:
path: ~/.cache/pre-commit
key: pre-commit|${{ matrix.python }}|${{ hashFiles('.pre-commit-config.yaml') }}
- if: matrix.toxenv == 'style'
+ if: matrix.tox == 'style'
- run: pip install tox
- - run: tox -e ${{ matrix.toxenv }}
+ - run: tox -e ${{ matrix.tox }}