summaryrefslogtreecommitdiff
path: root/isort/settings.py
diff options
context:
space:
mode:
Diffstat (limited to 'isort/settings.py')
-rw-r--r--isort/settings.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/isort/settings.py b/isort/settings.py
index 34f658a7..5a00fa16 100644
--- a/isort/settings.py
+++ b/isort/settings.py
@@ -348,10 +348,10 @@ def _get_config_data(file_path: str, sections: Iterable[str]) -> Dict[str, Any]:
config_section = config_section.get(key, {})
settings.update(config_section)
else:
- warnings.warn(
- "Found %s but toml package is not installed. To configure "
- "isort with %s, install with 'isort[pyproject]'." % (file_path, file_path)
- )
+ if '[tool.isort]' in config_file.read():
+ warnings.warn("Found {} with [tool.isort] section, but toml package is not installed. "
+ "To configure isort with {}, install with 'isort[pyproject]'.".format(file_path,
+ file_path))
else:
if file_path.endswith('.editorconfig'):
line = '\n'