summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.cruft.json2
-rw-r--r--isort/profiles.py1
-rw-r--r--pyproject.toml2
3 files changed, 3 insertions, 2 deletions
diff --git a/.cruft.json b/.cruft.json
index 37fced16..267b8fcb 100644
--- a/.cruft.json
+++ b/.cruft.json
@@ -1,6 +1,6 @@
{
"template": "https://github.com/timothycrosley/cookiecutter-python/",
- "commit": "2d559dc6413338a6ee05f4239039a88a17e7d2a9",
+ "commit": "5f2c774c99969c8483d7f329e38db5b1a7fc5050",
"context": {
"cookiecutter": {
"full_name": "Timothy Crosley",
diff --git a/isort/profiles.py b/isort/profiles.py
index 669c8277..1210c8ef 100644
--- a/isort/profiles.py
+++ b/isort/profiles.py
@@ -6,6 +6,7 @@ black = {
"include_trailing_comma": True,
"force_grid_wrap": 0,
"use_parentheses": True,
+ "ensure_newline_before_comments": True,
}
django = {
"combine_as_imports": True,
diff --git a/pyproject.toml b/pyproject.toml
index fd6d075e..9b7ba816 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -47,7 +47,7 @@ vulture = "^1.0"
bandit = "^1.6"
safety = "^1.8"
flake8-bugbear = "^19.8"
-black = {version = "^18.3-alpha.0", allows-prereleases = true}
+black = {version = "^18.3-alpha.0", allow-prereleases = true}
mypy = "^0.730.0"
ipython = "^7.7"
pytest = "^5.0"