summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--isort/finders.py6
-rw-r--r--tox.ini1
2 files changed, 2 insertions, 5 deletions
diff --git a/isort/finders.py b/isort/finders.py
index d3a3c074..04887ba9 100644
--- a/isort/finders.py
+++ b/isort/finders.py
@@ -287,10 +287,8 @@ class PipfileFinder(ReqsBaseFinder):
def _get_names(self, path):
with chdir(path):
project = Pipfile.load(path)
- sections = project.get_sections()
- for section in sections.values():
- for name in section:
- yield name
+ for req in project.packages:
+ yield req.name
def _get_files_from_dir(self, path):
if 'Pipfile' in os.listdir(path):
diff --git a/tox.ini b/tox.ini
index 6b0c12c9..07ec1973 100644
--- a/tox.ini
+++ b/tox.ini
@@ -16,7 +16,6 @@ commands = py.test test_isort.py {posargs}
commands = python setup.py isort
[testenv:lint]
-basepython = python3.6
deps = flake8==3.5.0
commands = flake8
skip_install = True