summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml2
-rw-r--r--tox.ini8
2 files changed, 9 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 6b23c0db..e79ee219 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,6 +3,8 @@ language: python
matrix:
include:
- env: TOXENV=isort-check
+ - python: 3.6
+ env: TOXENV=lint
- python: 2.6
env: TOXENV=py26
- python: 2.7
diff --git a/tox.ini b/tox.ini
index 1ee185be..97473031 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,7 +6,8 @@
[tox]
envlist =
isort-check,
- py26, py27, py33, py34, py35, py36, pypy
+ py26, py27, py33, py34, py35, py36, pypy,
+ lint
[testenv]
commands =
@@ -20,3 +21,8 @@ commands =
python setup.py isort
deps =
six
+
+[testenv:lint]
+basepython = python2.7
+deps = flake8
+commands = flake8 isort setup.py test_isort.py