summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-12-02 15:48:55 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2019-02-16 08:02:39 -0800
commit3c54c0e4177b2c92db40161a83397f1b221de57d (patch)
tree30f558a1d21cf9ffd5ffdaf09253cf592936d952 /tox.ini
parentbf67c678c13f5052623a968764263e934551db62 (diff)
downloadisort-3c54c0e4177b2c92db40161a83397f1b221de57d.tar.gz
Make isort run with Python 3 only
As isort is primarily used as a command-line tool, it is in a good position to move to Python 3 only. Other command-line-only tools have begun moving to Python 3. For example: black, mypy, pylint, and Sphinx. It will continue to support formatting Python 2 code, so users can still format their Python 2 projects. Allows for many code cleanups. By removing these workarounds, the project will be easier to maintain and reduce testing resources. Python 2 is scheduled to be EOL on January 1, 2020. The Python community is moving on. https://www.python.org/dev/peps/pep-0373/ For reasons to drop Python 2 support, see: https://python3statement.org/ For an overview of projects that have dropped Python 2 support entirely, see: https://hugovk.github.io/drop-python/2.7/ Fixes #808
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini3
1 files changed, 2 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 0e5b1db9..cb36b189 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,7 +3,7 @@ minversion = 2.4
envlist =
isort-check,
lint,
- py{27,34,35,36,37,py,py3}
+ py{34,35,36,37,py3}
[testenv]
deps =
@@ -15,6 +15,7 @@ extras =
commands = py.test test_isort.py {posargs}
[testenv:isort-check]
+basepython = python3
commands = python setup.py isort
[testenv:lint]