summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:15:29 +0100
committerBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:26:47 +0100
commitea10824e12e7d9409e7a8918094c1dbfa2d66f05 (patch)
treef028c5fe9f86109f90793270426ab296a76d8a3b /tox.ini
parent74ddc39485c18cb78972fc0088f82b8af7b24c53 (diff)
downloadisort-ea10824e12e7d9409e7a8918094c1dbfa2d66f05.tar.gz
Add Setuptools integration issue #261
These changes enable any user that installs `isort` to check his source code from setup.py with the command `python setup.py isort` I also checked isort package code with his command in tox and travis. Acknowledgements: this is mostly inspired by flake8 setuptools integration, see [flake8 doc](http://flake8.readthedocs.org/en/2.2.3/setuptools.html)
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini12
1 files changed, 10 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index d8d7b905..94f069d7 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,9 +4,17 @@
# and then run "tox" from this directory.
[tox]
-envlist = py26, py27, py32, py33, py34, pypy
+envlist =
+ isort-check,
+ py26, py27, py32, py33, py34, pypy
[testenv]
-commands = py.test {posargs}
+commands =
+ py.test {posargs}
deps =
pytest
+
+[testenv:isort-check]
+commands =
+ python setup.py isort
+deps =