summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorAlex Chan <alex@alexwlchan.net>2017-06-01 22:49:07 +0100
committerAlex Chan <alex@alexwlchan.net>2017-06-01 22:49:07 +0100
commit9e347fa9b22bf4e786aef00292ac6a5425d7da6a (patch)
treea781a23c861e228217d967a1e5e7ad5d9563921e /tox.ini
parent73b5adc97d665e31d3ef6146ed852ece11aea837 (diff)
downloadisort-9e347fa9b22bf4e786aef00292ac6a5425d7da6a.tar.gz
Add linting in Travis
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 1ee185be..97473031 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,7 +6,8 @@
[tox]
envlist =
isort-check,
- py26, py27, py33, py34, py35, py36, pypy
+ py26, py27, py33, py34, py35, py36, pypy,
+ lint
[testenv]
commands =
@@ -20,3 +21,8 @@ commands =
python setup.py isort
deps =
six
+
+[testenv:lint]
+basepython = python2.7
+deps = flake8
+commands = flake8 isort setup.py test_isort.py