summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2018-02-01 00:30:46 -0800
committerTimothy Crosley <timothy.crosley@gmail.com>2018-02-01 00:30:46 -0800
commit104b2e4ae4eee050ccef764f2cd7fb276a889b32 (patch)
treecd07aa3e44cf40210416a9d818c1f115c5c2e485 /setup.py
parent769af3f490a55cfc9d0995da534c00f7f643d6ce (diff)
downloadisort-104b2e4ae4eee050ccef764f2cd7fb276a889b32.tar.gz
Fix Python2 install
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c488e6e0..0af4550d 100755
--- a/setup.py
+++ b/setup.py
@@ -38,6 +38,10 @@ except ImportError:
with open('README.rst', 'r') as f:
readme = f.read()
+install_requires == []
+if sys.version_info.major == 2:
+ install_requires = ['futures']
+
setup(name='isort',
version='4.3.0',
description='A Python utility / library to sort Python imports.',
@@ -54,8 +58,9 @@ setup(name='isort',
'pylama.linter': ['isort = isort.pylama_isort:Linter'],
},
packages=['isort'],
+ install_requires=install_requires,
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- extra_requires={"python_version==1.7'": ["futures"]},
+ extra_requires={"python_version==1.7'": ['futures']},
cmdclass={'test': PyTest},
keywords='Refactor, Python, Python2, Python3, Refactoring, Imports, Sort, Clean',
classifiers=['Development Status :: 6 - Mature',