summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2018-09-22 22:06:04 -0700
committerGitHub <noreply@github.com>2018-09-22 22:06:04 -0700
commit384d79948adfeff682100299963531c6fae5f1a3 (patch)
treee6fe2f49d9bce050f81668eb3d30f5becf614cc0 /README.rst
parent709dce1af80cd7901c7844d1ea049249a876d28d (diff)
parent8e831f364621eaab152bb7b3308a1ed0418f7326 (diff)
downloadisort-384d79948adfeff682100299963531c6fae5f1a3.tar.gz
Merge branch 'develop' into pyproject-toml-support
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst20
1 files changed, 16 insertions, 4 deletions
diff --git a/README.rst b/README.rst
index 343bf739..d20fa9ff 100644
--- a/README.rst
+++ b/README.rst
@@ -29,7 +29,7 @@ isort your python imports for you so you don't have to.
isort is a Python utility / library to sort imports alphabetically, and automatically separated into sections.
It provides a command line utility, Python library and `plugins for various editors <https://github.com/timothycrosley/isort/wiki/isort-Plugins>`_ to quickly sort all your imports.
-It currently cleanly supports Python 2.7 - 3.6 without any dependencies.
+It currently cleanly supports Python 2.7 and 3.4+ without any dependencies.
.. image:: https://raw.github.com/timothycrosley/isort/develop/example.gif
:alt: Example Usage
@@ -86,11 +86,23 @@ Installing isort is as simple as:
pip install isort
-or if you prefer
+Install isort with requirements.txt support:
.. code-block:: bash
- easy_install isort
+ pip install isort[requirements]
+
+Install isort with Pipfile support:
+
+.. code-block:: bash
+
+ pip install isort[pipfile]
+
+Install isort with both formats support:
+
+.. code-block:: bash
+
+ pip install isort[requirements,pipfile]
Using isort
===========
@@ -238,7 +250,7 @@ To configure isort for a single user create a ``~/.isort.cfg`` file:
Additionally, you can specify project level configuration simply by placing a ``.isort.cfg`` file at the root of your
project. isort will look up to 25 directories up, from the file it is ran against, to find a project specific configuration.
-If you prefer, you can add an isort section to your project's ``setup.cfg`` or ``tox.ini`` file with any desired settings.
+Or, if you prefer, you can add an ``isort`` or ``tool:isort`` section to your project's ``setup.cfg`` or ``tox.ini`` file with any desired settings.
You can also add your desired settings under a ``[tool.isort]`` section in your ``pyproject.toml`` file.