summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2021-04-01 20:43:18 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2021-04-01 20:43:18 -0700
commit3896dae9df9fb084634763f62485d7cd5808c2b2 (patch)
treeb1bf36f5636a400fe73dad64359650fb7f25a23f
parentf01a8e02dee3549d8942ebd117a20eb6d219d7e8 (diff)
downloadisort-3896dae9df9fb084634763f62485d7cd5808c2b2.tar.gz
Add optional setuptools installation
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c4c60012..6cd4f6af 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -44,11 +44,13 @@ pipreqs = {version = "*", optional = true}
requirementslib = {version = "*", optional = true}
pip-api = {version = "*", optional = true}
colorama = {version = "^0.4.3", optional = true}
+setuptools = {version = "*", optional = true}
[tool.poetry.extras]
pipfile_deprecated_finder = ["pipreqs", "requirementslib", "pip-shims<=0.3.4"]
requirements_deprecated_finder = ["pipreqs", "pip-api"]
colors = ["colorama"]
+plugins = ["setuptools"]
[tool.poetry.dev-dependencies]
vulture = "^1.0"