summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2021-03-14 23:20:19 -0700
committerGitHub <noreply@github.com>2021-03-14 23:20:19 -0700
commit2a7f57c65bf5d1d882e1314d0ed1f524427dcbe8 (patch)
treec4f23e84b1b028a97cddc950681c695e08564f95
parentd09acd0974847314278e18c92db13950555e0ae9 (diff)
parent748cbe461fb949ee833a934b65d3e413e850b40d (diff)
downloadisort-2a7f57c65bf5d1d882e1314d0ed1f524427dcbe8.tar.gz
Merge pull request #1691 from cclauss/patch-3
GitHub Actions: Upgrade actions/cache and actions/setup-python
-rw-r--r--.github/workflows/integration.yml4
-rw-r--r--.github/workflows/lint.yml4
-rw-r--r--.github/workflows/test.yml8
3 files changed, 8 insertions, 8 deletions
diff --git a/.github/workflows/integration.yml b/.github/workflows/integration.yml
index 28310311..3f66a7ef 100644
--- a/.github/workflows/integration.yml
+++ b/.github/workflows/integration.yml
@@ -13,7 +13,7 @@ jobs:
- uses: actions/checkout@v2
- name: pip cache
- uses: actions/cache@v1
+ uses: actions/cache@v2
with:
path: ~/.cache/pip
key: integration-pip-${{ hashFiles('**/pyproject.toml') }}
@@ -21,7 +21,7 @@ jobs:
integration-pip-
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v1
+ uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
diff --git a/.github/workflows/lint.yml b/.github/workflows/lint.yml
index 06780574..af9158bc 100644
--- a/.github/workflows/lint.yml
+++ b/.github/workflows/lint.yml
@@ -13,7 +13,7 @@ jobs:
- uses: actions/checkout@v2
- name: pip cache
- uses: actions/cache@v1
+ uses: actions/cache@v2
with:
path: ~/.cache/pip
key: lint-pip-${{ hashFiles('**/pyproject.toml') }}
@@ -21,7 +21,7 @@ jobs:
lint-pip-
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v1
+ uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index ef93a1ee..1238f7ff 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -14,7 +14,7 @@ jobs:
steps:
- uses: actions/checkout@v2
- name: Ubuntu cache
- uses: actions/cache@v1
+ uses: actions/cache@v2
if: startsWith(matrix.os, 'ubuntu')
with:
path: ~/.cache/pip
@@ -24,7 +24,7 @@ jobs:
${{ matrix.os }}-${{ matrix.python-version }}-
- name: macOS cache
- uses: actions/cache@v1
+ uses: actions/cache@v2
if: startsWith(matrix.os, 'macOS')
with:
path: ~/Library/Caches/pip
@@ -34,7 +34,7 @@ jobs:
${{ matrix.os }}-${{ matrix.python-version }}-
- name: Windows cache
- uses: actions/cache@v1
+ uses: actions/cache@v2
if: startsWith(matrix.os, 'windows')
with:
path: c:\users\runneradmin\appdata\local\pip\cache
@@ -44,7 +44,7 @@ jobs:
${{ matrix.os }}-${{ matrix.python-version }}-
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v1
+ uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}