summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-10-13 21:53:44 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-10-13 21:53:44 -0700
commit055ce0f3fc30e4a0b3f9e067a22a533449e11e22 (patch)
treeef180e0ce3cbd3f4c2c9b433a0d9ce1efb0c19d9
parent9da6d8c6bced1b27e51227f7fc55fe1985faca86 (diff)
downloadisort-055ce0f3fc30e4a0b3f9e067a22a533449e11e22.tar.gz
Update to latest cruft template
-rw-r--r--.cruft.json2
-rw-r--r--.travis.yml1
-rw-r--r--pyproject.toml7
-rwxr-xr-xscripts/lint.sh1
4 files changed, 7 insertions, 4 deletions
diff --git a/.cruft.json b/.cruft.json
index 65ead87d..58738b68 100644
--- a/.cruft.json
+++ b/.cruft.json
@@ -1,6 +1,6 @@
{
"template": "https://github.com/timothycrosley/cookiecutter-python/",
- "commit": "28d4514e7f2a769c8014b8b5cd33ea24cfe3a53b",
+ "commit": "e8f19ccb7e1fb89d55e022ecd5e16b2269269f37",
"context": {
"cookiecutter": {
"full_name": "Timothy Crosley",
diff --git a/.travis.yml b/.travis.yml
index 7acd4c27..fcd18c84 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,6 +3,7 @@ language: python
cache: pip
install:
- pip3 install poetry
+- pip3 install cruft
- poetry install
matrix:
include:
diff --git a/pyproject.toml b/pyproject.toml
index 72a60bf5..1cc44123 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -53,6 +53,7 @@ pytest = "^5.0"
pytest-cov = "^2.7"
pytest-mock = "^1.10"
pep8-naming = "^0.8.2"
+cruft = { version = "^1.1", optional = true, python = "^3.6" }
portray = { version = "^1.3.0", optional = true, python = "^3.6" }
appdirs = "^1.4"
pipfile = "^0.0.2"
@@ -70,10 +71,10 @@ isort = "isort.main:ISortCommand"
[tool.poetry.plugins."pylama.linter"]
isort = "isort = isort.pylama_isort:Linter"
+[tool.portray.mkdocs.theme]
+name = "material"
+palette = {primary = "blue", accent = "light blue"}
[build-system]
requires = ["poetry>=0.12"]
build-backend = "poetry.masonry.api"
-[tool.portray.mkdocs.theme]
-name = "material"
-palette = {primary = "blue", accent = "light blue"}
diff --git a/scripts/lint.sh b/scripts/lint.sh
index e252401e..17717ef8 100755
--- a/scripts/lint.sh
+++ b/scripts/lint.sh
@@ -1,5 +1,6 @@
#!/bin/bash -xe
+cruft check
poetry run mypy --ignore-missing-imports isort/
poetry run isort --multi-line=3 --trailing-comma --force-grid-wrap=0 --use-parentheses --line-width=100 --recursive --check --diff --recursive isort/ tests/
poetry run black --check -l 100 isort/ tests/