summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-03-23 22:37:18 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-03-23 22:37:18 -0700
commit90984631b99e27095829a3abcceb279fb7b12032 (patch)
tree2af3574c8bab613c73ce428273867fb1f303b7ba
parentda01262b8f03b70e889d3b1255e041978f6d40d9 (diff)
downloadisort-90984631b99e27095829a3abcceb279fb7b12032.tar.gz
Fix issue #907, adding minimal appdirs requirement version
-rw-r--r--CHANGELOG.md1
-rwxr-xr-xsetup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d656640d..3939c45a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -2,6 +2,7 @@ Changelog
=========
### 4.3.16 - March 23, 2019 - hot fix release
- Fixed issue #909 - skip and skip-glob are not enforced when using settings-path
+- Fixed issue #907 - appdirs optional requirement does not correctly specify version
### 4.3.15 - March 10, 2019 - hot fix release
- Fixed a regression with handling streaming input from pipes (Issue #895)
diff --git a/setup.py b/setup.py
index 6ce5ef3a..4a934681 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ setup(name='isort',
'pipfile': ['pipreqs', 'requirementslib'],
'pyproject': ['toml'],
'requirements': ['pip', 'pipreqs'],
- 'xdg_home': ['appdirs'],
+ 'xdg_home': ['appdirs>=1.4.0'],
},
install_requires=[
'futures; python_version < "3.2"',