summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-03-06 08:15:40 -0800
committerTimothy Crosley <timothy.crosley@gmail.com>2019-03-06 08:15:40 -0800
commit138a4a1fb16cdabee09450df5ffdb6096d9fb7e2 (patch)
tree937b04771aaf390b388f2e8b248f7c48ae62560c
parent6eb47254bf57f241b33122528e70e4ac80e12be2 (diff)
downloadisort-138a4a1fb16cdabee09450df5ffdb6096d9fb7e2.tar.gz
Prepare changelog for 4.3.12 release4.3.12
-rw-r--r--CHANGELOG.md3
-rw-r--r--isort/__init__.py2
-rw-r--r--isort/finders.py3
-rwxr-xr-xsetup.py2
4 files changed, 7 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5819916a..3682f6cc 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,8 @@
Changelog
=========
+### 4.3.12 - March 6, 2019 - hot fix release
+- Fix error caused when virtual environment not detected
+
### 4.3.11 - March 6, 2019 - hot fix release
- Fixed issue #876: confused by symlinks pointing to virtualenv gives FIRSTPARTY not THIRDPARTY
- Fixed issue #873: current version skips every file on travis
diff --git a/isort/__init__.py b/isort/__init__.py
index ca921a53..6d518920 100644
--- a/isort/__init__.py
+++ b/isort/__init__.py
@@ -25,4 +25,4 @@ from __future__ import absolute_import, division, print_function, unicode_litera
from . import settings # noqa: F401
from .isort import SortImports # noqa: F401
-__version__ = "4.3.11"
+__version__ = "4.3.12"
diff --git a/isort/finders.py b/isort/finders.py
index 537e8491..fc9e8cf7 100644
--- a/isort/finders.py
+++ b/isort/finders.py
@@ -140,7 +140,8 @@ class PathFinder(BaseFinder):
# virtual env
self.virtual_env = self.config.get('virtual_env') or os.environ.get('VIRTUAL_ENV')
- self.virtual_env = os.path.realpath(self.virtual_env)
+ if self.virtual_env:
+ self.virtual_env = os.path.realpath(self.virtual_env)
self.virtual_env_src = False
if self.virtual_env:
self.virtual_env_src = '{0}/src/'.format(self.virtual_env)
diff --git a/setup.py b/setup.py
index 1af81cb5..f284e169 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ with open('README.rst') as f:
readme = f.read()
setup(name='isort',
- version='4.3.11',
+ version='4.3.12',
description='A Python utility / library to sort Python imports.',
long_description=readme,
author='Timothy Crosley',