summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2019-03-23 23:30:36 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-03-24 18:22:59 -0700
commitfa84e03d03a1c11e538177d83c73a3fa589a5c36 (patch)
treec4d550b5f853ef974c8e8fbd6ffe62e7ec9144b5
parent571fed2a4bf42b09526af5f1242fa727416505c1 (diff)
downloadisort-fa84e03d03a1c11e538177d83c73a3fa589a5c36.tar.gz
Merge pull request #912 from timothycrosley/feature/fix-issue-907
Fix issue #907, adding minimal appdirs requirement version
-rw-r--r--CHANGELOG.md1
-rwxr-xr-xsetup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 0f4a00cc..94f5ecfa 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -15,6 +15,7 @@ Planned:
### 4.3.16 - March 23, 2019 - hot fix release
- Fixed issue #909 - skip and skip-glob are not enforced when using settings-path.
+- Fixed issue #907 - appdirs optional requirement does not correctly specify version
- Fixed issue #778 - remove `user` from known standard library as it's no longer in any supported Python version.
### 4.3.15 - March 10, 2019 - hot fix release
diff --git a/setup.py b/setup.py
index 796354a0..52e4a2a9 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ setup(name='isort',
'pipfile': ['pipreqs', 'requirementslib'],
'pyproject': ['toml'],
'requirements': ['pip', 'pipreqs'],
- 'xdg_home': ['appdirs'],
+ 'xdg_home': ['appdirs>=1.4.0'],
},
python_requires=">=3.4",
keywords='Refactor, Python, Python3, Refactoring, Imports, Sort, Clean',