summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-03-06 08:15:40 -0800
committerTimothy Crosley <timothy.crosley@gmail.com>2019-03-06 08:25:10 -0800
commit0a64cc1b7c57c77dbcd9854ef51fb1ecf4b53063 (patch)
treea21acd3faac1f0a5cc58c44af4405cc80c81d7a5
parent169029f33e9ee9477d266a6a172df3f9b79bff8e (diff)
downloadisort-0a64cc1b7c57c77dbcd9854ef51fb1ecf4b53063.tar.gz
Merge in hot fix release
-rw-r--r--CHANGELOG.md5
-rw-r--r--isort/__init__.py2
-rw-r--r--isort/finders.py3
-rwxr-xr-xsetup.py2
4 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d4b66cae..97a68a00 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -11,7 +11,10 @@ Internal:
Planned:
- profile support for common project types (black, django, google, etc)
-### 4.3.11 - March 3, 2019 - hot fix release
+### 4.3.12 - March 6, 2019 - hot fix release
+- Fix error caused when virtual environment not detected
+
+### 4.3.11 - March 6, 2019 - hot fix release
- Fixed issue #876: confused by symlinks pointing to virtualenv gives FIRSTPARTY not THIRDPARTY
- Fixed issue #873: current version skips every file on travis
- Additional caching to reduce performance regression introduced in 4.3.5
diff --git a/isort/__init__.py b/isort/__init__.py
index e3af789b..342606e8 100644
--- a/isort/__init__.py
+++ b/isort/__init__.py
@@ -22,4 +22,4 @@ OTHER DEALINGS IN THE SOFTWARE.
from . import settings # noqa: F401
from .isort import SortImports # noqa: F401
-__version__ = "4.3.10"
+__version__ = "4.3.12"
diff --git a/isort/finders.py b/isort/finders.py
index 11f481ab..dcfaf8a6 100644
--- a/isort/finders.py
+++ b/isort/finders.py
@@ -128,7 +128,8 @@ class PathFinder(BaseFinder):
# virtual env
self.virtual_env = self.config.get('virtual_env') or os.environ.get('VIRTUAL_ENV')
- self.virtual_env = os.path.realpath(self.virtual_env)
+ if self.virtual_env:
+ self.virtual_env = os.path.realpath(self.virtual_env)
self.virtual_env_src = ''
if self.virtual_env:
self.virtual_env_src = '{0}/src/'.format(self.virtual_env)
diff --git a/setup.py b/setup.py
index 3a4360b7..4e798eed 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ with open('README.rst') as f:
readme = f.read()
setup(name='isort',
- version='4.3.10',
+ version='4.3.12',
description='A Python utility / library to sort Python imports.',
long_description=readme,
author='Timothy Crosley',