summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-05-01 22:14:57 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-05-01 22:16:36 -0700
commit01196cde0f9ab343f415b7cd035222e6a52f8264 (patch)
treeae454edd14d72e7e340fda1aae394307a8b00bf6
parent80500b9d031166dc973727d0c689590be2f287e5 (diff)
downloadisort-01196cde0f9ab343f415b7cd035222e6a52f8264.tar.gz
Hot-fix Release 4.3.18
-rw-r--r--CHANGELOG.md6
-rw-r--r--isort/__init__.py2
-rwxr-xr-xsetup.py2
3 files changed, 8 insertions, 2 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 792cde0a..09c2df72 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -13,6 +13,12 @@ Internal:
Planned:
- profile support for common project types (black, django, google, etc)
+### 4.3.18 - May 1, 2019 - hot fix release
+- Fixed an issue with parsing files that contain unicode characters in Python 2
+- Fixed issue #924 - Pulling in pip internals causes depreciation warning
+- Fixed issue #938 - Providing a way to filter explicitly passed in files via configuration settings (`--filter-files`)
+- Improved interoperability with toml configuration files
+
### 4.3.17 - April 7, 2019 - hot fix release
- Fixed issue #905 & #919: Import section headers behaving strangely
diff --git a/isort/__init__.py b/isort/__init__.py
index dd113998..3b63fee9 100644
--- a/isort/__init__.py
+++ b/isort/__init__.py
@@ -22,4 +22,4 @@ OTHER DEALINGS IN THE SOFTWARE.
from . import settings # noqa: F401
from .compat import SortImports # noqa: F401
-__version__ = "4.3.17"
+__version__ = "4.3.18"
diff --git a/setup.py b/setup.py
index 810a5aaf..99b4e1ff 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ with open('README.rst') as f:
readme = f.read()
setup(name='isort',
- version='4.3.17',
+ version='4.3.18',
description='A Python utility / library to sort Python imports.',
long_description=readme,
author='Timothy Crosley',