summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2019-03-23 23:30:36 -0700
committerGitHub <noreply@github.com>2019-03-23 23:30:36 -0700
commitcd653c3115aa8da993fb4e9f722f2cb9780199c0 (patch)
tree8ec733ff5260c846cee61659ee0055c2840194cf
parent136b8d90b397fcbcad4e243b1ea75589bf0c565b (diff)
parent675d23535ffd76a702827c06d5b97740a224c0c5 (diff)
downloadisort-cd653c3115aa8da993fb4e9f722f2cb9780199c0.tar.gz
Merge pull request #912 from timothycrosley/feature/fix-issue-907
Fix issue #907, adding minimal appdirs requirement version
-rw-r--r--CHANGELOG.md1
-rwxr-xr-xsetup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 358e1600..f85ff4a1 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,6 +3,7 @@ Changelog
### 4.3.16 - March 23, 2019 - hot fix release
- Fixed issue #909 - skip and skip-glob are not enforced when using settings-path.
+- Fixed issue #907 - appdirs optional requirement does not correctly specify version
- Fixed issue #778 - remove `user` from known standard library as it's no longer in any supported Python version.
### 4.3.15 - March 10, 2019 - hot fix release
diff --git a/setup.py b/setup.py
index 6ce5ef3a..4a934681 100755
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ setup(name='isort',
'pipfile': ['pipreqs', 'requirementslib'],
'pyproject': ['toml'],
'requirements': ['pip', 'pipreqs'],
- 'xdg_home': ['appdirs'],
+ 'xdg_home': ['appdirs>=1.4.0'],
},
install_requires=[
'futures; python_version < "3.2"',