summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-05-07 05:12:35 -0700
committerJon Dufresne <jon.dufresne@gmail.com>2017-05-30 07:51:25 -0700
commit8559b531cdc48f7b191cd05e0a0f02c48fef5574 (patch)
treea54b623ccfccee589386efcc82399fa5e7bde4f4 /.travis.yml
parent8edea62bb8159aa49c8a1a2bdda8ca90cb6ae607 (diff)
downloadisort-8559b531cdc48f7b191cd05e0a0f02c48fef5574.tar.gz
Drop support for Python 2.6
I would humbly like to suggest isort drops support for Python 2.6. The last release of Python 2.6 was 2013-10-29, over 3 years ago. It is no longer receiving security fixes. https://www.python.org/dev/peps/pep-0361/ The pip project itself has recently dropped support for 2.6. Their numbers estimate that Python 2.6 accounts for ~2% of their downloads. See: https://github.com/pypa/pip/pull/4343 For projects that still use Python 2.6, they can continue to pip install an older version of isort. I've tried my best to remove as much 2.6 specific code as I can, including the 'Programming Language :: Python :: 2.6' trove classifier from setup.py. I've also removed Travis CI testing, which should result in faster testing and fewer wasted resources. Code changed: - Removed Python2.6 from documentation - Removed Python2.6 from testing configuration - Use set literals - Use dict comprehension - Pass generator expressions to builtin functions instead of lists - Use builtin OrderedDict - Removed deprecated U open mode; replace with io.open() which support universal newlines - Removed Python2.6 workarounds throughout the code Thanks for considering.
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml2
1 files changed, 0 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 6b23c0db..cc8354b6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,8 +3,6 @@ language: python
matrix:
include:
- env: TOXENV=isort-check
- - python: 2.6
- env: TOXENV=py26
- python: 2.7
env: TOXENV=py27
- python: 3.3