summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:15:29 +0100
committerBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:26:47 +0100
commitea10824e12e7d9409e7a8918094c1dbfa2d66f05 (patch)
treef028c5fe9f86109f90793270426ab296a76d8a3b /.travis.yml
parent74ddc39485c18cb78972fc0088f82b8af7b24c53 (diff)
downloadisort-ea10824e12e7d9409e7a8918094c1dbfa2d66f05.tar.gz
Add Setuptools integration issue #261
These changes enable any user that installs `isort` to check his source code from setup.py with the command `python setup.py isort` I also checked isort package code with his command in tox and travis. Acknowledgements: this is mostly inspired by flake8 setuptools integration, see [flake8 doc](http://flake8.readthedocs.org/en/2.2.3/setuptools.html)
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml20
1 files changed, 12 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 02bae897..5ed06553 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,13 @@
language: python
-python:
- - "pypy"
- - "2.6"
- - "2.7"
- - "3.2"
- - "3.3"
- - "3.4"
-script: python setup.py test
+env:
+ - TOXENV=isort-check
+ - TOXENV=py26
+ - TOXENV=py27
+ - TOXENV=py32
+ - TOXENV=py33
+ - TOXENV=py34
+ - TOXENV=pypy
+install:
+ - pip install tox
+script:
+ - tox -e $TOXENV