summaryrefslogtreecommitdiff
path: root/.editorconfig
diff options
context:
space:
mode:
authorBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:15:29 +0100
committerBenjamin ABEL <bbig26@gmail.com>2015-03-02 19:26:47 +0100
commitea10824e12e7d9409e7a8918094c1dbfa2d66f05 (patch)
treef028c5fe9f86109f90793270426ab296a76d8a3b /.editorconfig
parent74ddc39485c18cb78972fc0088f82b8af7b24c53 (diff)
downloadisort-ea10824e12e7d9409e7a8918094c1dbfa2d66f05.tar.gz
Add Setuptools integration issue #261
These changes enable any user that installs `isort` to check his source code from setup.py with the command `python setup.py isort` I also checked isort package code with his command in tox and travis. Acknowledgements: this is mostly inspired by flake8 setuptools integration, see [flake8 doc](http://flake8.readthedocs.org/en/2.2.3/setuptools.html)
Diffstat (limited to '.editorconfig')
-rw-r--r--.editorconfig10
1 files changed, 9 insertions, 1 deletions
diff --git a/.editorconfig b/.editorconfig
index e2da10c7..5e1a36e2 100644
--- a/.editorconfig
+++ b/.editorconfig
@@ -9,4 +9,12 @@ known_third_party = kate
ignore_frosted_errors = E103
skip = runtests.py,build
balanced_wrapping = true
-not_skip = __init__.py \ No newline at end of file
+not_skip = __init__.py
+
+[*.{rst,ini}]
+indent_style = space
+indent_size = 4
+
+[*.yml]
+indent_style = space
+indent_size = 2