summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Weis <gerhard.weis@gmx.com>2012-01-06 11:41:17 +1000
committerGerhard Weis <gerhard.weis@gmx.com>2012-01-06 11:41:17 +1000
commit9c7ab8362e2d4867c87f6011ba1623df3a079b65 (patch)
tree0b7f74568816abd38cb7b60ebce1fee3b0a7b8b6
parent9742cbac7799548d58febe97e54533f72fa9d7c7 (diff)
downloadisodate-9c7ab8362e2d4867c87f6011ba1623df3a079b65.tar.gz
* made setuptools an optional dependency
* bumped version to 0.4.5
-rw-r--r--CHANGES.txt5
-rw-r--r--README.txt4
-rw-r--r--setup.py17
3 files changed, 18 insertions, 8 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 2565f68..e68b105 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -2,6 +2,11 @@
CHANGES
=======
+0.4.5 (2012-01-06)
+------------------
+
+- made setuptools dependency optional
+
0.4.4 (2011-04-16)
------------------
diff --git a/README.txt b/README.txt
index ce2d2c2..9c789c2 100644
--- a/README.txt
+++ b/README.txt
@@ -73,7 +73,9 @@ Installation:
-------------
This module can easily be installed with Python standard installation methods.
-Just use *setuptools* or *easy_install* as usual.
+
+Either use *python setup.py install* or in case you have *setuptools* or
+*distribute* available, you can also use *easy_install*.
Limitations:
------------
diff --git a/setup.py b/setup.py
index 9bf49ca..f565c3b 100644
--- a/setup.py
+++ b/setup.py
@@ -26,18 +26,21 @@
# CONTRACT, STRICT LIABILITY, OR TORT
##############################################################################
import os
-from setuptools import setup
-from setuptools import find_packages
-# for setuptools see: http://peak.telecommunity.com/DevCenter/setuptools
+setupargs = {}
+
+try:
+ from setuptools import setup
+ setupargs['test_suite'] = 'tests.test_suite'
+except ImportError:
+ from distutils.core import setup
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
-
setup(name='isodate',
- version='0.4.4',
- packages=find_packages('src', exclude=["tests"]),
+ version='0.4.5',
+ packages=['isodate',],
package_dir={'': 'src'},
# dependencies:
@@ -64,5 +67,5 @@ setup(name='isodate',
'Topic :: Internet',
'Topic :: Software Development :: Libraries :: Python Modules',
],
- test_suite="tests.test_suite"
+ **setupargs
)