summaryrefslogtreecommitdiff
path: root/tags/1.1.1/setup.py
diff options
context:
space:
mode:
authorMichael Shields <mshields@google.com>2015-08-17 17:00:30 -0700
committerMichael Shields <mshields@google.com>2015-08-17 17:00:30 -0700
commit2814495325ebe1b2aeff7362739d7929a96bccde (patch)
tree3488d7b2ba683964b2178dac29872f3795a14829 /tags/1.1.1/setup.py
parenta054c3823522f2cb77fffa0e31f8f29c50060601 (diff)
parentc813f4790d1092b1515ee18fe8270180ed3cc5cb (diff)
downloadipaddr-py-2814495325ebe1b2aeff7362739d7929a96bccde.tar.gz
Merge branch 'master' of github.com:google/ipaddr-py
Diffstat (limited to 'tags/1.1.1/setup.py')
-rwxr-xr-xtags/1.1.1/setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/tags/1.1.1/setup.py b/tags/1.1.1/setup.py
new file mode 100755
index 0000000..6088ced
--- /dev/null
+++ b/tags/1.1.1/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/python
+#
+# Copyright 2008 Google Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from distutils.core import setup
+
+import ipaddr
+
+
+setup(name='ipaddr',
+ maintainer='Google',
+ maintainer_email='ipaddr-py-dev@googlegroups.com',
+ version=ipaddr.__version__,
+ url='http://code.google.com/p/ipaddr-py/',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Networking'],
+ py_modules=['ipaddr'])