summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile7
-rwxr-xr-xpython2/httplib2test.py (renamed from httplib2test.py)0
2 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f6ee31c..164d6a7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,12 @@
tests:
- python httplib2test.py
+ cd python2 && python2.4 httplib2test.py
+ cd python2 && python2.5 httplib2test.py
+ cd python2 && python2.6 httplib2test.py
+ cd python3 && python3.1 httplib2test.py
VERSION = $(shell python setup.py --version)
DST = dist/httplib2-$(VERSION)
+
release:
-mkdir dist
-rm -rf dist/httplib2-$(VERSION)
@@ -15,7 +19,6 @@ release:
cd dist && tar -czv -f httplib2-$(VERSION).tar.gz httplib2-$(VERSION)
cd dist && zip httplib2-$(VERSION).zip -r httplib2-$(VERSION)
-
doc:
#pudge -v -f --modules=httplib2 --dest=build/doc
diff --git a/httplib2test.py b/python2/httplib2test.py
index 5bab45e..5bab45e 100755
--- a/httplib2test.py
+++ b/python2/httplib2test.py