summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoe Gregorio <jcgregorio@google.com>2011-06-23 15:41:24 -0400
committerJoe Gregorio <jcgregorio@google.com>2011-06-23 15:41:24 -0400
commitb470dc487f16f441d5f5c88f4606dcd2b2605d37 (patch)
treea5934b8a071f062648c7e273044c613ff60a104a /Makefile
parent905b8b64a4baa86308c47c35797b7fff015665f8 (diff)
downloadhttplib2-b470dc487f16f441d5f5c88f4606dcd2b2605d37.tar.gz
Change out Go Daddy root ca for their ca bundle. Also add checks for version number matching when doing releases.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5f3e5c2..94ae182 100644
--- a/Makefile
+++ b/Makefile
@@ -8,9 +8,13 @@ tests:
cd python3 && python3.2 httplib2test.py
VERSION = $(shell python setup.py --version)
+INLINE_VERSION = $(shell cd python2; python -c "import httplib2;print httplib2.__version__")
+INLINE_VERSION_3 = $(shell cd python3; python3.2 -c "import httplib2;print(httplib2.__version__)")
DST = dist/httplib2-$(VERSION)
release:
+ [ "$(VERSION)" == "$(INLINE_VERSION)" ] # Check for version number mismatch
+ [ "$(VERSION)" == "$(INLINE_VERSION_3)" ] # Check for version number mismatch
-find . -name "*.pyc" | xargs rm
-find . -name "*.orig" | xargs rm
-rm -rf python2/.cache