summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJoe Gregorio <joe@bitworking.org>2009-12-24 10:06:02 -0500
committerJoe Gregorio <joe@bitworking.org>2009-12-24 10:06:02 -0500
commit25dffefd19323728d8dea13e798d56ae4347884b (patch)
treeb2c7961240f689ecc7391c2526381ee4a543abc8 /Makefile
parent16db63afe28f5d4cf1b2aa74f9656c0cce5f683d (diff)
downloadhttplib2-25dffefd19323728d8dea13e798d56ae4347884b.tar.gz
Tests are now run on 2.4, 2.5, 2.6 and 3.1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index f6ee31c..164d6a7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,12 @@
tests:
- python httplib2test.py
+ cd python2 && python2.4 httplib2test.py
+ cd python2 && python2.5 httplib2test.py
+ cd python2 && python2.6 httplib2test.py
+ cd python3 && python3.1 httplib2test.py
VERSION = $(shell python setup.py --version)
DST = dist/httplib2-$(VERSION)
+
release:
-mkdir dist
-rm -rf dist/httplib2-$(VERSION)
@@ -15,7 +19,6 @@ release:
cd dist && tar -czv -f httplib2-$(VERSION).tar.gz httplib2-$(VERSION)
cd dist && zip httplib2-$(VERSION).zip -r httplib2-$(VERSION)
-
doc:
#pudge -v -f --modules=httplib2 --dest=build/doc