summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Gregorio <joe@bitworking.org>2009-07-19 01:32:17 -0400
committerJoe Gregorio <joe@bitworking.org>2009-07-19 01:32:17 -0400
commit66611ff0bcfbe0d7b053d378d577ad914b1e57af (patch)
treee0c9fe2f46ac9016e90d25751b508bd7cbe300a2
parent60e8624ce63626335162a2e30c74983cfa3ffc64 (diff)
downloadhttplib2-66611ff0bcfbe0d7b053d378d577ad914b1e57af.tar.gz
Updates in preparation for making the 0.5.0 release
-rwxr-xr-xCHANGELOG13
-rwxr-xr-xMakefile2
-rwxr-xr-xsetup.py7
3 files changed, 18 insertions, 4 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 8138c04..6c6f2db 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,16 @@
+0.5.0
+
+ Added Python 3 support
+
+ Fixed the following bugs:
+
+ #12 - Cache-Control: only-if-cached incorrectly does request if item not in cache
+ #39 - Deprecation warnings in Python 2.6
+ #56 - Block on response.read() for HEAD requests.
+ #57 - Timeout ignore for Python 2.6
+ #58 - Fixed parsing of Cache-Control: header to make it more robust
+
+
0.4.0
Added support for proxies if the Socksipy module is installed.
diff --git a/Makefile b/Makefile
index 205786c..560bd1a 100755
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
tests:
python httplib2test.py
release:
- python2.4 setup.py sdist --formats=gztar,zip
+ python setup.py sdist --formats=gztar,zip
doc:
#pudge -v -f --modules=httplib2 --dest=build/doc
/usr/lib/python2.5/doc/tools/mkhowto --html ref.tex
diff --git a/setup.py b/setup.py
index d18a2c9..b29dafb 100755
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,11 @@
from distutils.core import setup
-VERSION = '0.4.0'
+VERSION = '0.5.0'
setup(name='httplib2',
version=VERSION,
author='Joe Gregorio',
author_email='joe@bitworking.org',
- url='http://bitworking.org/projects/httplib2/',
- download_url='http://bitworking.org/projects/httplib2/dist/httplib2-%s.tar.gz' % VERSION,
+ url='http://code.google.com/p/httplib2/',
+ download_url='http://httplib2.googlecode.com/files/httplib2-%s.tar.gz' % VERSION,
description='A comprehensive HTTP client library.',
license='MIT',
long_description="""
@@ -60,6 +60,7 @@ A comprehensive HTTP client library, ``httplib2`` supports many features left ou
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
'Topic :: Internet :: WWW/HTTP',
'Topic :: Software Development :: Libraries',
],