summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWouter Bolsterlee <uws@xs4all.nl>2013-11-06 23:12:37 +0100
committerWouter Bolsterlee <uws@xs4all.nl>2013-11-06 23:12:37 +0100
commit914f88a2317a48914f3f522af1c9214acb951324 (patch)
tree55db280875a7f5829c88eef5f21357c88245fe91
parent0d9f9621d6e762171f4d3701fb8afc660f5c7e31 (diff)
downloadhappybase-914f88a2317a48914f3f522af1c9214acb951324.tar.gz
Coding style cleanups in setup.py
-rw-r--r--setup.py42
1 files changed, 22 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 731de9f..d10aef2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
from os.path import join, dirname
from setuptools import find_packages, setup
+__version__ = None
execfile('happybase/_version.py')
@@ -19,23 +20,24 @@ def get_install_requires():
return install_requires
-setup(name='happybase',
- version=__version__,
- description="A developer-friendly Python library to interact "
- "with Apache HBase",
- long_description=get_file_contents('README.rst'),
- author="Wouter Bolsterlee",
- author_email="uws@xs4all.nl",
- url='https://github.com/wbolster/happybase',
- install_requires=get_install_requires(),
- packages=find_packages(exclude=['tests']),
- license="MIT",
- classifiers=(
- "Development Status :: 4 - Beta",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Programming Language :: Python :: 2",
- "Topic :: Database",
- "Topic :: Software Development :: Libraries :: Python Modules",
- )
- )
+setup(
+ name='happybase',
+ version=__version__,
+ description="A developer-friendly Python library to interact with "
+ "Apache HBase",
+ long_description=get_file_contents('README.rst'),
+ author="Wouter Bolsterlee",
+ author_email="uws@xs4all.nl",
+ url='https://github.com/wbolster/happybase',
+ install_requires=get_install_requires(),
+ packages=find_packages(exclude=['tests']),
+ license="MIT",
+ classifiers=(
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2",
+ "Topic :: Database",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ )
+)