summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Borzenkov <snaury@gmail.com>2014-10-18 17:26:56 +0400
committerAlexey Borzenkov <snaury@gmail.com>2014-10-18 17:26:56 +0400
commita64ae10a1b1cc27fdf2dc638bd2519396d2625ba (patch)
treefa1d70e8c66db202fe82611ca092f682013fe4ce
parent0c5036d2c09a5feaf8ad999f190126aea504d02b (diff)
downloadgreenlet-a64ae10a1b1cc27fdf2dc638bd2519396d2625ba.tar.gz
Nothing special needed when using VC++ for Python and setuptools
-rwxr-xr-xmake-win-release4
-rw-r--r--run_vs2010_x64.cmd4
2 files changed, 1 insertions, 7 deletions
diff --git a/make-win-release b/make-win-release
index 8bf94c4..149b6b5 100755
--- a/make-win-release
+++ b/make-win-release
@@ -2,7 +2,7 @@
import sys, os, subprocess, re
-common_dist = ("bdist_wininst", "bdist_msi", "bdist_wheel", "bdist_egg", "test")
+common_dist = ("bdist_wheel", "bdist_egg", "test")
pyver2dist = {
"Python26": common_dist,
"Python26x64": common_dist,
@@ -40,8 +40,6 @@ def main():
here = os.path.dirname(os.path.dirname(sys.executable))
for pyver, dists in sorted(pyver2dist.items()):
exe = os.path.join(here, pyver, "python.exe")
- if pyver.endswith('x64'):
- exe = "run_vs2010_x64.cmd " + exe
for d in dists:
cmd = "%s setup.py -q %s" % (exe, d)
system(cmd)
diff --git a/run_vs2010_x64.cmd b/run_vs2010_x64.cmd
deleted file mode 100644
index df7a968..0000000
--- a/run_vs2010_x64.cmd
+++ /dev/null
@@ -1,4 +0,0 @@
-@echo off
-call "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.Cmd" /Release /x64 /xp
-set GREENLET_STATIC_RUNTIME=1
-%*