summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sthiel@thoughtworks.com>2019-07-29 08:11:21 +0800
committerSebastian Thiel <sthiel@thoughtworks.com>2019-08-11 14:40:42 +0800
commit2e7e82b114a5c1b3eb61f171c376e1cf85563d07 (patch)
tree6dacb948f8fd22038623bc6ecd81c1d6dd5d59d0 /setup.py
parent0b6b90f9f1e5310a6f39b75e17a04c1133269e8f (diff)
downloadgitpython-2e7e82b114a5c1b3eb61f171c376e1cf85563d07.tar.gz
Drop python 2 support, again (revert previous revert)
This reverts commit 913d806f02cf50250d230f88b897350581f80f6b.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 49288f69..65656d55 100755
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ setup(
package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
license="BSD License",
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=3.0, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -102,8 +102,6 @@ setup(
"Operating System :: Microsoft :: Windows",
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",