summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sthiel@thoughtworks.com>2019-07-20 17:26:16 +0800
committerSebastian Thiel <sthiel@thoughtworks.com>2019-07-20 17:34:19 +0800
commitdac619e4917b0ad43d836a534633d68a871aecca (patch)
tree7b6608753801c576014a6b5de396230a4ec2bb5b /setup.py
parent1bb0b1751b38da43dbcd2ec58e71eb7b0138d786 (diff)
downloadgitpython-dac619e4917b0ad43d836a534633d68a871aecca.tar.gz
Drop python 2.7 support and help with encodings
Fixes #312
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 49288f69..65656d55 100755
--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,7 @@ setup(
package_data={'git.test': ['fixtures/*']},
package_dir={'git': 'git'},
license="BSD License",
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=3.0, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -102,8 +102,6 @@ setup(
"Operating System :: Microsoft :: Windows",
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",