summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-11-14 16:10:26 +0100
committerSebastian Thiel <byronimo@gmail.com>2014-11-14 16:15:31 +0100
commitc914637ab146c23484a730175aa10340db91be70 (patch)
treed40ad34a07acdaab828f82ff05029f897bb20bc9 /README.md
parente1ad78eb7494513f6c53f0226fe3cb7df4e67513 (diff)
parentd43055d44e58e8f010a71ec974c6a26f091a0b7a (diff)
downloadgitpython-c914637ab146c23484a730175aa10340db91be70.tar.gz
Merge branch 'tox' of https://github.com/hashar/GitPython into hashar-tox
Conflicts: README.md requirements.txt setup.py
Diffstat (limited to 'README.md')
-rw-r--r--README.md21
1 files changed, 18 insertions, 3 deletions
diff --git a/README.md b/README.md
index a3800f92..44b55748 100644
--- a/README.md
+++ b/README.md
@@ -13,6 +13,9 @@ The object database implementation is optimized for handling large quantities of
- Tested with nose 1.3.0
* Mock by Michael Foord used for tests
- Tested with 1.0.1
+* Coverage - used for tests coverage
+
+The list of dependencies are listed in /requirements.txt and /test-requirements.txt. The installer takes care of installing them for you though.
### INSTALL
@@ -22,15 +25,27 @@ The object database implementation is optimized for handling large quantities of
If you have downloaded the source code:
python setup.py install
-
-or if you want to obtain a copy more easily:
+
+or if you want to obtain a copy from the Pypi repository:
pip install gitpython
-
+
+Both commands will install the required package dependencies.
+
A distribution package can be obtained for manual installation at:
http://pypi.python.org/pypi/GitPython
+### RUNNING TESTS
+
+The easiest way to run test is by using [tox](https://pypi.python.org/pypi/tox) a wrapper around virtualenv. It will take care of setting up environnements with the proper dependencies installed and execute test commands. To install it simply:
+
+ pip install tox
+
+Then run:
+
+ tox
+
### SOURCE
GitPython's git repo is available on GitHub, which can be browsed at [github](https://github.com/gitpython-developers/GitPython) and cloned like that: