summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorAntoine Musso <hashar@free.fr>2014-07-25 11:01:30 +0200
committerAntoine Musso <hashar@free.fr>2014-07-25 11:20:27 +0200
commit2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c (patch)
tree82dbc96c2b43f6e188a256b05cc395d99765e165 /README.md
parentdbd784b870a878ef6dbecd14310018cdaeda5c6d (diff)
downloadgitpython-2ddd5e5ef89da7f1e3b3a7d081fbc7f5c46ac11c.tar.gz
Use tox to easily run tests in venv
tox https://pypi.python.org/pypi/tox is a thin wrapper around virtualenv which let you craft a fresh python environement to execute command in. It creates the env with virtualenv, install dependencies, run python setup.py install in it and then execute whatever command you want it to do and report status. To do so I simply: - listed tests dependencies in test-requirements.txt (which are just nose and mock) - provide a tox.ini file which describe how to install the dependencies and execute nosetests - added the module 'coverage' to the list of test dependencies To run tests simply: pip install tox && tox That will execute the test command 'nosetests' using python2.6 and then python 2.7. The additional env 'cover' can be run using: tox -ecover.
Diffstat (limited to 'README.md')
-rw-r--r--README.md13
1 files changed, 12 insertions, 1 deletions
diff --git a/README.md b/README.md
index 0b5f5a2a..fcf74c3d 100644
--- a/README.md
+++ b/README.md
@@ -13,8 +13,9 @@ The object database implementation is optimized for handling large quantities of
- Tested with nose 1.3.0
* Mock by Michael Foord used for tests
- Tested with 1.0.1
+* Coverage - used for tests coverage
-The list of dependencies are listed in /requirements.txt. The installer takes care of installing them for you though.
+The list of dependencies are listed in /requirements.txt and /test-requirements.txt. The installer takes care of installing them for you though.
### INSTALL
@@ -32,6 +33,16 @@ A distribution package can be obtained for manual installation at:
http://pypi.python.org/pypi/GitPython
+### RUNNING TESTS
+
+The easiest way to run test is by using [tox](https://pypi.python.org/pypi/tox) a wrapper around virtualenv. It will take care of setting up environnements with the proper dependencies installed and execute test commands. To install it simply:
+
+ pip install tox
+
+Then run:
+
+ tox
+
### DEVELOPMENT STATUS
[![Build Status](https://travis-ci.org/gitpython-developers/GitPython.svg?branch=0.3)](https://travis-ci.org/gitpython-developers/GitPython)