summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2014-05-04 16:53:36 +0200
committerSebastian Thiel <byronimo@gmail.com>2014-05-04 16:55:27 +0200
commit1f225d4b8c3d7eb90038c246a289a18c7b655da2 (patch)
treedd909dd43a72e86cd9acd6a229ec0b5aefda1715 /README.md
parent9e91a05aabb73cca7acec1cc0e07d8a562e31b45 (diff)
downloadgitpython-1f225d4b8c3d7eb90038c246a289a18c7b655da2.tar.gz
Added support for travis ci
Diffstat (limited to 'README.md')
-rw-r--r--README.md63
1 files changed, 63 insertions, 0 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 00000000..c081f25f
--- /dev/null
+++ b/README.md
@@ -0,0 +1,63 @@
+## GitPython
+
+.. image:: https://travis-ci.org/gitpython-developers/GitPython.svg?branch=master :target: https://travis-ci.org/gitpython-developers/GitPython
+
+GitPython is a python library used to interact with git repositories, high-level like git-porcelain, or low-level like git-plumbing.
+
+It provides abstractions of git objects for easy access of repository data, and additionally allows you to access the git repository more directly using either a pure python implementation, or the faster, but more resource intensive git command implementation.
+
+The object database implementation is optimized for handling large quantities of objects and large datasets, which is achieved by using low-level structures and data streaming.
+
+### REQUIREMENTS
+
+* Git ( tested with 1.8.3.4 )
+* Python Nose - used for running the tests
+ - Tested with nose 1.3.0
+* Mock by Michael Foord used for tests
+ - Tested with 1.0.1
+
+### INSTALL
+
+If you have downloaded the source code:
+
+ python setup.py install
+
+or if you want to obtain a copy more easily:
+
+ pip install gitpython
+
+A distribution package can be obtained for manual installation at:
+
+ http://pypi.python.org/pypi/GitPython
+
+### SOURCE
+
+
+GitPython's git repo is available on GitHub, which can be browsed at:
+
+https://github.com/gitpython-developers/GitPython
+
+and cloned using:
+
+git clone git://github.com/gitpython-developers/GitPython.git git-python
+
+
+### DOCUMENTATION
+
+The html-compiled documentation can be found at the following URL:
+
+http://packages.python.org/GitPython/
+
+### MAILING LIST
+
+http://groups.google.com/group/git-python
+
+### ISSUE TRACKER
+
+Issues are tracked on github:
+
+https://github.com/gitpython-developers/GitPython/issues
+
+### LICENSE
+
+New BSD License. See the LICENSE file.