summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames E. King III <jking@apache.org>2019-01-15 16:16:33 -0500
committerSebastian Thiel <byronimo@gmail.com>2019-05-05 13:22:53 +0530
commitce21f63f7acba9b82cea22790c773e539a39c158 (patch)
tree8c63814a486cee0a66ee092aad90cc3997b1dfd2
parent1f66e25c25cde2423917ee18c4704fff83b837d1 (diff)
downloadgitpython-ce21f63f7acba9b82cea22790c773e539a39c158.tar.gz
Fix setup.py and use of requirements files.
-rw-r--r--.appveyor.yml7
-rw-r--r--.travis.yml3
-rw-r--r--MANIFEST.in4
-rw-r--r--Makefile2
-rw-r--r--git/cmd.py3
-rw-r--r--requirements.txt3
-rwxr-xr-xsetup.py14
-rw-r--r--test-requirements.txt5
8 files changed, 23 insertions, 18 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 8eeca501..2df96e42 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -16,6 +16,12 @@ environment:
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "%GIT_DAEMON_PATH%"
+ - PYTHON: "C:\\Python36-x64"
+ PYTHON_VERSION: "3.6"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
+ - PYTHON: "C:\\Python37-x64"
+ PYTHON_VERSION: "3.7"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Miniconda35-x64"
PYTHON_VERSION: "3.5"
IS_CONDA: "yes"
@@ -51,6 +57,7 @@ install:
conda info -a &
conda install --yes --quiet pip
)
+ - pip install -r requirements.txt
- pip install -r test-requirements.txt
- pip install codecov
diff --git a/.travis.yml b/.travis.yml
index adb693dd..c0c38a34 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -40,8 +40,7 @@ script:
- ulimit -n 128
- ulimit -n
- nosetests -v --with-coverage
- - if [ "$TRAVIS_PYTHON_VERSION" == '3.4' ]; then flake8 --ignore=W293,E265,E266,W503,W504,E731; fi
- if [ "$TRAVIS_PYTHON_VERSION" == '3.5' ]; then cd doc && make html; fi
- -
+ - if [ "$TRAVIS_PYTHON_VERSION" == '3.6' ]; then flake8 --ignore=W293,E265,E266,W503,W504,E731; fi
after_success:
- codecov
diff --git a/MANIFEST.in b/MANIFEST.in
index 15ac959e..e6bf5249 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -2,8 +2,10 @@ include VERSION
include LICENSE
include CHANGES
include AUTHORS
-include README
+include CONTRIBUTING.md
+include README.md
include requirements.txt
+include test-requirements.txt
recursive-include doc *
diff --git a/Makefile b/Makefile
index 648b8595..764b822b 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ all:
@grep -Ee '^[a-z].*:' Makefile | cut -d: -f1 | grep -vF all
clean:
- rm -rf build/ dist/
+ rm -rf build/ dist/ .eggs/ .tox/
release: clean
# Check if latest tag is the current head we're releasing
diff --git a/git/cmd.py b/git/cmd.py
index a4faefe2..1b24a626 100644
--- a/git/cmd.py
+++ b/git/cmd.py
@@ -220,7 +220,8 @@ class Git(LazyMixin):
# - a GitCommandNotFound error is spawned by ourselves
# - a PermissionError is spawned if the git executable provided
# cannot be executed for whatever reason
- exceptions = (GitCommandNotFound, PermissionError)
+ exceptions = (GitCommandNotFound, PermissionError) # noqa
+ # (silence erroneous flake8 F821)
has_git = False
try:
diff --git a/requirements.txt b/requirements.txt
index 39644606..63d5ddfe 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,2 +1 @@
-gitdb>=0.6.4
-ddt>=1.1.1
+gitdb2 (>=2.0.0)
diff --git a/setup.py b/setup.py
index cb0300f7..9959fdbd 100755
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,9 @@ with open(path.join(path.dirname(__file__), 'VERSION')) as v:
with open('requirements.txt') as reqs_file:
requirements = reqs_file.read().splitlines()
+with open('test-requirements.txt') as reqs_file:
+ test_requirements = reqs_file.read().splitlines()
+
class build_py(_build_py):
@@ -63,10 +66,6 @@ def _stamp_version(filename):
print("WARNING: Couldn't find version line in file %s" % filename, file=sys.stderr)
-install_requires = ['gitdb2 >= 2.0.0']
-test_requires = ['ddt>=1.1.1']
-# end
-
setup(
name="GitPython",
cmdclass={'build_py': build_py, 'sdist': sdist},
@@ -81,9 +80,8 @@ setup(
package_dir={'git': 'git'},
license="BSD License",
python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
- requires=['gitdb2 (>=2.0.0)'],
- install_requires=install_requires,
- test_requirements=test_requires + install_requires,
+ requires=requirements,
+ tests_require=requirements + test_requirements,
zip_safe=False,
long_description="""GitPython is a python library used to interact with Git repositories""",
classifiers=[
@@ -110,6 +108,6 @@ setup(
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.7"
]
)
diff --git a/test-requirements.txt b/test-requirements.txt
index 1cea3aa2..084925a1 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,6 +1,5 @@
--r requirements.txt
-
+ddt>=1.1.1
coverage
flake8
nose
-mock; python_version=='2.7' \ No newline at end of file
+mock; python_version=='2.7'