summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Verges <xavier.verges@es.ibm.com>2020-10-04 20:55:10 +0200
committerSebastian Thiel <sebastian.thiel@icloud.com>2020-10-05 08:12:04 +0800
commit0c6e67013fd22840d6cd6cb1a22fcf52eecab530 (patch)
tree3d55f68cf3d07cece5a0604baf43ceaa3315381a
parent4ba76d683df326f2e6d4f519675baf86d0373abf (diff)
downloadgitpython-0c6e67013fd22840d6cd6cb1a22fcf52eecab530.tar.gz
Keep flake happy
-rw-r--r--test/test_installation.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/test/test_installation.py b/test/test_installation.py
index 3b39a328..6117be98 100644
--- a/test/test_installation.py
+++ b/test/test_installation.py
@@ -28,8 +28,10 @@ class TestInstallation(TestBase):
self.assertEqual(0, result.returncode, msg=result.stderr or result.stdout or "Can't build - setup.py failed")
result = subprocess.run([self.python, '-c', 'import git'], stdout=subprocess.PIPE, cwd=self.sources)
self.assertEqual(0, result.returncode, msg=result.stderr or result.stdout or "Selftest failed")
- result = subprocess.run([self.python, '-c', 'import sys;import git; print(sys.path)'], stdout=subprocess.PIPE, cwd=self.sources)
- syspath = result.stdout.decode('utf-8').splitlines()[0]
+ result = subprocess.run([self.python, '-c', 'import sys;import git; print(sys.path)'],
+ stdout=subprocess.PIPE, cwd=self.sources)
+ syspath = result.stdout.decode('utf-8').splitlines()[0]
syspath = ast.literal_eval(syspath)
- self.assertEqual('', syspath[0], msg='Failed to follow the conventions for https://docs.python.org/3/library/sys.html#sys.path')
+ self.assertEqual('', syspath[0],
+ msg='Failed to follow the conventions for https://docs.python.org/3/library/sys.html#sys.path')
self.assertTrue(syspath[1].endswith('gitdb'), msg='Failed to add gitdb to sys.path')