summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryobmod <yobmod@gmail.com>2021-02-26 15:01:49 +0000
committeryobmod <yobmod@gmail.com>2021-02-26 15:01:49 +0000
commitf9b0e75c07ccbf90a9f2e67873ffbe672bb1a859 (patch)
treea7c1203d435544c129802c0d938dae80e9874398
parentc34c23a830bb45726c52bd5dcd84c2d5092418e4 (diff)
downloadgitpython-f9b0e75c07ccbf90a9f2e67873ffbe672bb1a859.tar.gz
rebase on master
-rw-r--r--.appveyor.yml3
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rw-r--r--doc/source/intro.rst2
-rwxr-xr-xsetup.py6
-rw-r--r--tox.ini2
7 files changed, 10 insertions, 8 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 49cf39bd..0a86c1a7 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -6,6 +6,9 @@ environment:
CYGWIN64_GIT_PATH: "C:\\cygwin64\\bin;%GIT_DAEMON_PATH%"
matrix:
+ - PYTHON: "C:\\Python34-x64"
+ PYTHON_VERSION: "3.4"
+ GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "%GIT_DAEMON_PATH%"
diff --git a/.gitignore b/.gitignore
index 68ada439..36965752 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,5 +18,3 @@ nbproject
/.vscode/
.idea/
.cache/
-.mypy_cache/
-.pytest_cache/ \ No newline at end of file
diff --git a/.travis.yml b/.travis.yml
index bb71ca41..1fbb1ddb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,6 +1,7 @@
# UNUSED, only for reference. If adjustments are needed, please see github actions
language: python
python:
+ - "3.4"
- "3.5"
- "3.6"
- "3.7"
diff --git a/README.md b/README.md
index 0d0edeb4..befb2afb 100644
--- a/README.md
+++ b/README.md
@@ -34,7 +34,7 @@ If it is not in your `PATH`, you can help GitPython find it by setting
the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
-* Python >= 3.5
+* Python >= 3.4
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`.
The installer takes care of installing them for you.
diff --git a/doc/source/intro.rst b/doc/source/intro.rst
index 7168c91b..638a9166 100644
--- a/doc/source/intro.rst
+++ b/doc/source/intro.rst
@@ -13,7 +13,7 @@ The object database implementation is optimized for handling large quantities of
Requirements
============
-* `Python`_ >= 3.5
+* `Python`_ >= 3.4
* `Git`_ 1.7.0 or newer
It should also work with older versions, but it may be that some operations
involving remotes will not work as expected.
diff --git a/setup.py b/setup.py
index 652cbd17..ef9dd33d 100755
--- a/setup.py
+++ b/setup.py
@@ -98,7 +98,7 @@ setup(
include_package_data=True,
py_modules=build_py_modules("./git", excludes=["git.ext.*"]),
package_dir={'git': 'git'},
- python_requires='>=3.5',
+ python_requires='>=3.4',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -122,10 +122,10 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
-
+ "Programming Language :: Python :: 3.8"
]
)
diff --git a/tox.ini b/tox.ini
index e5a2cd4b..532c78de 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py36,py37,py38,flake8
+envlist = py34,py35,py36,py37,py38,flake8
[testenv]
commands = python -m unittest --buffer {posargs}