summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryobmod <yobmod@gmail.com>2021-02-26 15:07:29 +0000
committeryobmod <yobmod@gmail.com>2021-02-26 15:07:29 +0000
commit803aca26d3f611f7dfd7148f093f525578d609ef (patch)
tree5e7d93998a037a7ba2939f2a96f8ab95102ff4ff
parentf9b0e75c07ccbf90a9f2e67873ffbe672bb1a859 (diff)
downloadgitpython-803aca26d3f611f7dfd7148f093f525578d609ef.tar.gz
add python 3.9 support
-rw-r--r--.github/workflows/pythonpackage.yml2
-rw-r--r--doc/source/changes.rst1
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
4 files changed, 5 insertions, 3 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index a4f76522..5e94cd05 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.5, 3.6, 3.7, 3.8]
+ python-version: [3.5, 3.6, 3.7, 3.8, 3.9]
steps:
- uses: actions/checkout@v2
diff --git a/doc/source/changes.rst b/doc/source/changes.rst
index 86cc5f37..cfb7f1fa 100644
--- a/doc/source/changes.rst
+++ b/doc/source/changes.rst
@@ -7,6 +7,7 @@ Changelog
* git.Commit objects now have a ``replace`` method that will return a
copy of the commit with modified attributes.
+* Add python 3.9 support
3.1.13
======
diff --git a/setup.py b/setup.py
index ef9dd33d..500e88c8 100755
--- a/setup.py
+++ b/setup.py
@@ -126,6 +126,7 @@ setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8"
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9"
]
)
diff --git a/tox.ini b/tox.ini
index 532c78de..4167cb63 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py34,py35,py36,py37,py38,flake8
+envlist = py34,py35,py36,py37,py38,py39,flake8
[testenv]
commands = python -m unittest --buffer {posargs}