summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYobmod <yobmod@gmail.com>2021-02-24 16:47:40 +0000
committerYobmod <yobmod@gmail.com>2021-02-24 16:47:40 +0000
commit2f8320b7bf75b6ec375ade605a9812b4b2147de9 (patch)
treea0403feef4f2ccbe7a7fef5bb88d007b589145fc
parentb3778ec37d17a6eb781fa9c6b5e2009fa7542d77 (diff)
downloadgitpython-2f8320b7bf75b6ec375ade605a9812b4b2147de9.tar.gz
drop python 3.4, update .gitignore
-rw-r--r--.appveyor.yml3
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml1
-rw-r--r--README.md2
-rw-r--r--doc/source/intro.rst2
-rw-r--r--errors.txt18
-rwxr-xr-xsetup.py6
-rw-r--r--tox.ini2
8 files changed, 26 insertions, 10 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
index 0a86c1a7..49cf39bd 100644
--- a/.appveyor.yml
+++ b/.appveyor.yml
@@ -6,9 +6,6 @@ environment:
CYGWIN64_GIT_PATH: "C:\\cygwin64\\bin;%GIT_DAEMON_PATH%"
matrix:
- - PYTHON: "C:\\Python34-x64"
- PYTHON_VERSION: "3.4"
- GIT_PATH: "%GIT_DAEMON_PATH%"
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5"
GIT_PATH: "%GIT_DAEMON_PATH%"
diff --git a/.gitignore b/.gitignore
index 36965752..68ada439 100644
--- a/.gitignore
+++ b/.gitignore
@@ -18,3 +18,5 @@ nbproject
/.vscode/
.idea/
.cache/
+.mypy_cache/
+.pytest_cache/ \ No newline at end of file
diff --git a/.travis.yml b/.travis.yml
index 1fbb1ddb..bb71ca41 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,7 +1,6 @@
# UNUSED, only for reference. If adjustments are needed, please see github actions
language: python
python:
- - "3.4"
- "3.5"
- "3.6"
- "3.7"
diff --git a/README.md b/README.md
index befb2afb..0d0edeb4 100644
--- a/README.md
+++ b/README.md
@@ -34,7 +34,7 @@ If it is not in your `PATH`, you can help GitPython find it by setting
the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
-* Python >= 3.4
+* Python >= 3.5
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`.
The installer takes care of installing them for you.
diff --git a/doc/source/intro.rst b/doc/source/intro.rst
index 638a9166..7168c91b 100644
--- a/doc/source/intro.rst
+++ b/doc/source/intro.rst
@@ -13,7 +13,7 @@ The object database implementation is optimized for handling large quantities of
Requirements
============
-* `Python`_ >= 3.4
+* `Python`_ >= 3.5
* `Git`_ 1.7.0 or newer
It should also work with older versions, but it may be that some operations
involving remotes will not work as expected.
diff --git a/errors.txt b/errors.txt
new file mode 100644
index 00000000..0d68c25d
--- /dev/null
+++ b/errors.txt
@@ -0,0 +1,18 @@
+PermissionError: [WinError 32] The process cannot access the file because it is being used by another process:
+'C:\\Users\\yobmod\\AppData\\Local\\Temp\\non_bare_test_root_modulebicpd1jd\\git\\ext\\gitdb' ->
+'C:\\Users\\yobmod\\AppData\\Local\\Temp\\non_bare_test_root_modulebicpd1jd\\path\\prefix\\git\\ext\\gitdb'
+
+======================================================================
+FAIL: test_conditional_includes_from_git_dir (test.test_config.TestBase)
+----------------------------------------------------------------------
+Traceback (most recent call last):
+ File "c:\dev\gitpython\test\lib\helper.py", line 91, in wrapper
+ return func(self, path)
+ File "c:\dev\gitpython\test\test_config.py", line 267, in test_conditional_includes_from_git_dir
+ assert config._has_includes()
+AssertionError
+
+----------------------------------------------------------------------
+Ran 409 tests in 118.716s
+
+FAILED (failures=1, errors=10, skipped=14) \ No newline at end of file
diff --git a/setup.py b/setup.py
index ef9dd33d..652cbd17 100755
--- a/setup.py
+++ b/setup.py
@@ -98,7 +98,7 @@ setup(
include_package_data=True,
py_modules=build_py_modules("./git", excludes=["git.ext.*"]),
package_dir={'git': 'git'},
- python_requires='>=3.4',
+ python_requires='>=3.5',
install_requires=requirements,
tests_require=requirements + test_requirements,
zip_safe=False,
@@ -122,10 +122,10 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8"
+ "Programming Language :: Python :: 3.8",
+
]
)
diff --git a/tox.ini b/tox.ini
index 532c78de..e5a2cd4b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py34,py35,py36,py37,py38,flake8
+envlist = py35,py36,py37,py38,flake8
[testenv]
commands = python -m unittest --buffer {posargs}