summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoryobmod <yobmod@gmail.com>2021-02-28 18:04:24 +0000
committeryobmod <yobmod@gmail.com>2021-02-28 18:04:24 +0000
commit2d92fee01b05e5e217e6dad5cc621801c31debae (patch)
tree380176227b1756460d39e8555c44c5c99235dbfa
parent9c6178f53233aa98a602854240a7a20b6537aa7b (diff)
downloadgitpython-2d92fee01b05e5e217e6dad5cc621801c31debae.tar.gz
add py.typed, mypy.ini and git/types.py
-rw-r--r--git/py.typed0
-rw-r--r--git/types.py6
-rw-r--r--mypy.ini4
-rwxr-xr-xsetup.py1
4 files changed, 11 insertions, 0 deletions
diff --git a/git/py.typed b/git/py.typed
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/git/py.typed
diff --git a/git/types.py b/git/types.py
new file mode 100644
index 00000000..19d20c24
--- /dev/null
+++ b/git/types.py
@@ -0,0 +1,6 @@
+import os
+from typing import Optional, Union, Any
+
+
+TBD = Any
+PathLike = Union[str, os.PathLike[str]] \ No newline at end of file
diff --git a/mypy.ini b/mypy.ini
new file mode 100644
index 00000000..72716491
--- /dev/null
+++ b/mypy.ini
@@ -0,0 +1,4 @@
+
+[mypy]
+
+disallow_untyped_defs = True \ No newline at end of file
diff --git a/setup.py b/setup.py
index 2acb4076..f8829c38 100755
--- a/setup.py
+++ b/setup.py
@@ -95,6 +95,7 @@ setup(
license="BSD",
url="https://github.com/gitpython-developers/GitPython",
packages=find_packages(exclude=("test.*")),
+ package_data={'git': ['**/*.pyi', 'py.typed']},
include_package_data=True,
py_modules=build_py_modules("./git", excludes=["git.ext.*"]),
package_dir={'git': 'git'},