summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2016-06-01 09:06:22 +0200
committerSebastian Thiel <byronimo@gmail.com>2016-06-01 09:06:22 +0200
commit543d900e68883740acf3b07026b262176191ab60 (patch)
tree7494f0653b859d84b4e3d498e3d07b0371c4edfe
parent6581acaa7081d29dbf9f35c5ce78db78cf822ab8 (diff)
downloadgitpython-543d900e68883740acf3b07026b262176191ab60.tar.gz
chore(compat): state py2.6 support officially
More information in the respective issue. Fixes #453
-rw-r--r--README.md2
-rwxr-xr-xsetup.py1
2 files changed, 3 insertions, 0 deletions
diff --git a/README.md b/README.md
index 220e8f35..b3c5c947 100644
--- a/README.md
+++ b/README.md
@@ -6,11 +6,13 @@ It provides abstractions of git objects for easy access of repository data, and
The object database implementation is optimized for handling large quantities of objects and large datasets, which is achieved by using low-level structures and data streaming.
+
### REQUIREMENTS
GitPython needs the `git` executable to be installed on the system and available in your `PATH` for most operations. If it is not in your `PATH`, you can help GitPython find it by setting the `GIT_PYTHON_GIT_EXECUTABLE=<path/to/git>` environment variable.
* Git (1.7.x or newer)
+* Python 2.7 to 3.5, while python 2.6 is supported on a *best-effort basis*.
The list of dependencies are listed in `./requirements.txt` and `./test-requirements.txt`. The installer takes care of installing them for you.
diff --git a/setup.py b/setup.py
index 2df910e0..05c12b8f 100755
--- a/setup.py
+++ b/setup.py
@@ -110,6 +110,7 @@ GitPython is a python library used to interact with Git repositories""",
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.3",