summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-10-01 17:50:49 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-10-01 17:50:49 +0200
commitbdf1e68f6bec679edc3feb455596e18c387879c4 (patch)
tree2a148931ae7b59d273fe17833f7440753c4b7b43
parentb8b025f719b2c3203e194580bbd0785a26c08ebd (diff)
parent4592785004ad1a4869d650dc35a1e9099245dad9 (diff)
downloadgitpython-bdf1e68f6bec679edc3feb455596e18c387879c4.tar.gz
Merge remote-tracking branch 'origin/master' into appveyor
-rw-r--r--README.md2
-rwxr-xr-xsetup.py22
2 files changed, 21 insertions, 3 deletions
diff --git a/README.md b/README.md
index a009deba..6632347f 100644
--- a/README.md
+++ b/README.md
@@ -136,4 +136,4 @@ return to a proper state, which means
* no open pull requests
* no open issues describing bugs
-[contributing]: https://github.com/gitpython-developers/GitPython/blob/master/README.md
+[contributing]: https://github.com/gitpython-developers/GitPython/blob/master/CONTRIBUTING.md
diff --git a/setup.py b/setup.py
index 2e8ee520..d644f005 100755
--- a/setup.py
+++ b/setup.py
@@ -9,6 +9,8 @@ except ImportError:
from distutils.command.build_py import build_py as _build_py
from setuptools.command.sdist import sdist as _sdist
+import pkg_resources
+import logging
import os
import sys
from os import path
@@ -68,10 +70,26 @@ def _stamp_version(filename):
print("WARNING: Couldn't find version line in file %s" % filename, file=sys.stderr)
install_requires = ['gitdb >= 0.6.4']
-test_requires = ['node', 'ddt']
+extras_require = {
+ ':python_version == "2.6"': ['ordereddict'],
+}
+test_requires = ['ddt']
if sys.version_info[:2] < (2, 7):
- install_requires.append('ordereddict')
test_requires.append('mock')
+
+try:
+ if 'bdist_wheel' not in sys.argv:
+ for key, value in extras_require.items():
+ if key.startswith(':') and pkg_resources.evaluate_marker(key[1:]):
+ install_requires.extend(value)
+except Exception:
+ logging.getLogger(__name__).exception(
+ 'Something went wrong calculating platform specific dependencies, so '
+ "you're getting them all!"
+ )
+ for key, value in extras_require.items():
+ if key.startswith(':'):
+ install_requires.extend(value)
# end
setup(