summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostis Anagnostopoulos <ankostis@gmail.com>2016-09-25 12:02:52 +0200
committerKostis Anagnostopoulos <ankostis@gmail.com>2016-09-25 18:35:03 +0200
commit1210ec763e1935b95a3a909c61998fbd251b7575 (patch)
tree8e44eae07d02c8d0407a2ee06b02e9f44739159a
parent7842e92ebaf3fc3380cc8d704afa3841f333748c (diff)
downloadgitpython-1210ec763e1935b95a3a909c61998fbd251b7575.tar.gz
apveyor: Wintest project with MINGW/Cygwin git (conda2.7&3.4/cpy-3.5)
[travisci skip]
-rw-r--r--.appveyor.yml74
-rw-r--r--README.md12
2 files changed, 80 insertions, 6 deletions
diff --git a/.appveyor.yml b/.appveyor.yml
new file mode 100644
index 00000000..2af0ccdb
--- /dev/null
+++ b/.appveyor.yml
@@ -0,0 +1,74 @@
+# CI on Windows via appveyor
+environment:
+
+ matrix:
+ - PYTHON: "C:\\Miniconda"
+ PYTHON_VERSION: "2.7"
+ - PYTHON: "C:\\Miniconda"
+ PYTHON_VERSION: "2.7"
+ GIT_PATH: "C:\\cygwin64\\bin"
+
+ - PYTHON: "C:\\Miniconda3-x64"
+ PYTHON_VERSION: "3.4"
+ - PYTHON: "C:\\Miniconda3-x64"
+ PYTHON_VERSION: "3.4"
+ GIT_PATH: "C:\\cygwin64\\bin"
+
+ - PYTHON: "C:\Python35-x64"
+ PYTHON_VERSION: "3.5"
+ - PYTHON: "C:\Python35-x64"
+ PYTHON_VERSION: "3.5"
+ GIT_PATH: "C:\\cygwin64\\bin"
+
+install:
+ - set PATH=%PYTHON%;%PYTHON%\Scripts;%GIT_PATH%;%PATH%
+
+ ## Print architecture, python & git used for debugging.
+ #
+ - |
+ uname -a
+ where git
+ python --version
+ python -c "import struct; print(struct.calcsize('P') * 8)"
+ conda info -a
+
+ - conda install --yes --quiet pip
+ - pip install nose wheel coveralls
+ - IF "%PYTHON_VERSION%"=="2.7" (
+ pip install mock
+ )
+
+ ## Copied from `init-tests-after-clone.sh`.
+ #
+ - |
+ git submodule update --init --recursive
+ git fetch --tags
+ git tag __testing_point__
+ git checkout master || git checkout -b master
+ git reset --hard HEAD~1
+ git reset --hard HEAD~1
+ git reset --hard HEAD~1
+ git reset --hard __testing_point__
+
+ ## For commits performed with the default user.
+ - |
+ git config --global user.email "travis@ci.com"
+ git config --global user.name "Travis Runner"
+
+ - python setup.py develop
+
+build: off
+
+test_script:
+ - |
+ echo "+++ Checking archives for PyPI repo..."
+ python setup.py bdist_wheel
+
+ - IF "%PYTHON_VERSION%"=="3.4" (
+ nosetests -v --with-coverage
+ ) ELSE (
+ nosetests -v
+ )
+
+#on_success:
+# - IF "%PYTHON_VERSION%"=="3.4" (coveralls)
diff --git a/README.md b/README.md
index b3308af2..12159a06 100644
--- a/README.md
+++ b/README.md
@@ -31,7 +31,7 @@ Both commands will install the required package dependencies.
A distribution package can be obtained for manual installation at:
http://pypi.python.org/pypi/GitPython
-
+
If you like to clone from source, you can do it like so:
```bash
@@ -45,7 +45,7 @@ git submodule update --init --recursive
#### Leakage of System Resources
GitPython is not suited for long-running processes (like daemons) as it tends to
-leak system resources. It was written in a time where destructors (as implemented
+leak system resources. It was written in a time where destructors (as implemented
in the `__del__` method) still ran deterministically.
In case you still want to use it in such a context, you will want to search the
@@ -61,7 +61,7 @@ as they are kept alive solely by their users, or not.
### RUNNING TESTS
-*Important*: Right after cloning this repository, please be sure to have executed the `init-tests-after-clone.sh` script in the repository root. Otherwise you will encounter test failures.
+*Important*: Right after cloning this repository, please be sure to have executed the `./init-tests-after-clone.sh` script in the repository root. Otherwise you will encounter test failures.
The easiest way to run test is by using [tox](https://pypi.python.org/pypi/tox) a wrapper around virtualenv. It will take care of setting up environnements with the proper dependencies installed and execute test commands. To install it simply:
@@ -70,8 +70,8 @@ The easiest way to run test is by using [tox](https://pypi.python.org/pypi/tox)
Then run:
tox
-
-
+
+
For more fine-grained control, you can use `nose`.
### Contributions
@@ -100,7 +100,7 @@ Please have a look at the [contributions file][contributing].
* Finally, set the upcoming version in the `VERSION` file, usually be
incrementing the patch level, and possibly by appending `-dev`. Probably you
want to `git push` once more.
-
+
### LICENSE
New BSD License. See the LICENSE file.